IP Library › Granted Patent US 12,261,769
Granted Patent B2
US 12,261,769 · App. 17/380,828 · Granted Mar 25, 2025

Source route compression

Inventor: Pranjal Kumar Dutta (Sunnyvale, CA)
Assignee: Nokia Solutions and Networks Oy
H04L45/34
View Patent ↗
Loading inventors, assignments & file history…
Monitor This Case
Get email alerts when status or documents change.
Order Certified Copies
Most orders are placed with the USPTO same day — all within 24 business hours.
Order via The Patent Place →
Pre-filled with this patent's details
Quick Facts
Patent No.
US 12,261,769
App. No.
17/380,828
Granted
Mar 25, 2025
Kind
B2
Abstract

Various example embodiments for supporting source routing are presented herein. Various example embodiments for supporting source routing may be configured to support source route compression for source routing. Various example for supporting source route compression for source routing may be configured to support communication of a source routed packet over a path from an ingress node to an egress node over a network, wherein the network includes a set of network elements having a respective set of network element identifiers sharing a common prefix, wherein the source routed packet has encoded therein a source route block including the common prefix and an offset list, wherein the offset list includes a set of offset values associated with respective ones of the network elements of the path and configured to be combined with the common prefix to recover the network element identifiers of the respective ones of the network elements of the path.

Claims (31)

1. An apparatus, comprising:

at least one processor; and

at least one memory including instructions that, when executed by the at least one processor, cause the apparatus at least to:

determine, for a path including a set of network elements having a respective set of network element identifiers associated therewith, a plurality of subsets of network elements of the path;

determine, for each of the plurality of subsets of network elements, a respective common prefix shared by the respective network element identifiers of respective ones of the network elements in the respective subset of network elements;

determine, for each of the plurality of subsets of network elements, a respective set of offset values associated with the respective ones of the network elements in the respective subset of network elements and configured to be combined with the respective common prefix for the respective subset of network elements to recover the respective network element identifiers of the respective ones of the network elements in the respective subset of network elements;

generate a set of source route blocks including, for each of the plurality of subsets of network elements, a respective source route block including the respective common prefix for the respective subset of network elements, a respective offset size value indicative of a size of each of the offset values in the respective set of offset values for the respective subset of network elements, and the respective set of offset values for the respective subset of network elements; and

send, toward a next hop of the path, a source routed packet including a header and a payload, wherein the header includes the set of source route blocks.

2. The apparatus of claim 1 , wherein the set of network elements includes each of the network elements of the network.

3. The apparatus of claim 1 , wherein the set of network elements includes at least one of a set of nodes or a set of links.

4. The apparatus of claim 1 , wherein, for at least one of the source route blocks, the respective common prefix for the respective subset of network elements includes an Internet Protocol (IP) prefix, a Multiprotocol Label Switching (MPLS) label value, or an Ethernet Media Access Control (MAC) Address prefix.

5. The apparatus of claim 1 , wherein at least one of the source route blocks is encoded using an Internet Protocol version 4 (IPv4) Options Header.

6. The apparatus of claim 1 , wherein at least one of the source route blocks is encoded using an Internet Protocol version 4 (IPv4) Shim header disposed between an IPV4 Header and a transport layer protocol header.

7. The apparatus of claim 1 , wherein at least one of the source route blocks is encoded using an Internet Protocol version 6 (IPv6) Extension Header (EH).

8. The apparatus of claim 1 , wherein at least one of the source route blocks is encoded using an Internet Protocol version 6 (IPv6) Shim header disposed between an IPv6 Header and a transport layer protocol header.

9. The apparatus of claim 1 , wherein at least one of the source route blocks is encoded using a Multiprotocol Label Switching (MPLS) label stack.

10. A method, comprising:

determining, for a path including a set of network elements having a respective set of network element identifiers associated therewith, a plurality of subsets of network elements of the path;

determining, for each of the plurality of subsets of network elements, a respective common prefix shared by the respective network element identifiers of respective ones of the network elements in the respective subset of network elements;

determining, for each of the plurality of subsets of network elements, a respective set of offset values associated with the respective ones of the network elements in the respective subset of network elements and configured to be combined with the respective common prefix for the respective subset of network elements to recover the respective network element identifiers of the respective ones of the network elements in the respective subset of network elements;

generating a set of source route blocks including, for each of the plurality of subsets of network elements, a respective source route block including the respective common prefix for the respective subset of network elements, a respective offset size value indicative of a size of each of the offset values in the respective set of offset values for the respective subset of network elements, and the respective set of offset values for the respective subset of network elements; and

sending, toward a next hop of the path, a source routed packet including a header and a payload, wherein the header includes the set of source route blocks.

11. An apparatus, comprising:

at least one processor; and

at least one memory including instructions that, when executed by the at least one processor, cause the apparatus at least to:

support communication of a source routed packet over a path including a set of network elements, wherein the network elements have associated therewith respective network element identifiers sharing a common prefix;

wherein the source routed packet includes a source route block including the common prefix and including a set of offset values associated with the respective network elements and configured to be combined with the common prefix to recover the respective network element identifiers of the respective network elements;

wherein the source route block includes a source route block indicator label configured to identify the source route block within the source routed packet;

wherein the source route block includes a base label including the common prefix;

wherein the source route block includes a source route block descriptor label including an offset size value indicative of a size of each of the offset values in set of offset values and including a number of offset values in the set of offset values; and

wherein the source route block includes an offset label stack including one or more offset labels including the set of offset values.

Assignments (4)
ASSIGNMENT OF ASSIGNOR'S INTEREST Recorded Jul 28, 2021
From: KUMAR DUTTA, PRANJAL
To: NOKIA OF AMERICA CORPORATION
Reel/Frame 056999/0167 →
ASSIGNMENT OF ASSIGNOR'S INTEREST Recorded Jul 28, 2021
From: NOKIA OF AMERICA CORPORATION
To: NOKIA SOLUTIONS AND NETWORKS OY
Reel/Frame 056999/0170 →
ASSIGNMENT OF ASSIGNOR'S INTEREST Recorded Jul 20, 2021
From: DUTTA, PRANJAL KUMAR
To: NOKIA OF AMERICA CORPORATION
Reel/Frame 056921/0149 →
ASSIGNMENT OF ASSIGNOR'S INTEREST Recorded Jul 20, 2021
From: NOKIA OF AMERICA CORPORATION
To: NOKIA SOLUTIONS AND NETWORKS OY
Reel/Frame 056921/0186 →
Continuity (1)
Related Publication 20230028147A1 · Jan 26, 2023
References Cited (34)
US 10917334B1 · Lamanna · 2021 [cited by examiner]
US 11356409B1 · Ng · 2022 [cited by examiner]
US 20050063352A1 · Amara · 2005 [cited by examiner]
US 20100027539A1 · Beverly · 2010 [cited by examiner]
US 20150256456A1 · Previdi · 2015 [cited by examiner]
US 20160020988A1 · Hui · 2016 [cited by examiner]
US 20160380887A1 · Black · 2016 [cited by examiner]
US 20170149685A1 · Wu · 2017 [cited by examiner]
US 20190020737A1 · Han · 2019 [cited by examiner]
US 20200287824A1 · Dutta · 2020 [cited by applicant]
US 20200351388A1 · Han · 2020 [cited by examiner]
US 20210211140A1 · Li · 2021 [cited by examiner]
US 20210306257A1 · Dutta · 2021 [cited by applicant]
US 20210306265A1 · K A · 2021 [cited by examiner]
US 20230122099A1 · Hu · 2023 [cited by examiner]
US 20230188463A1 · Cheng · 2023 [cited by examiner]
CN 112491708A · 2021 [cited by applicant]
CN 113014485A · 2021 [cited by applicant]
WO 2019011201A1 · 2019 [cited by applicant]
WO 2019239172A1 · 2019 [cited by applicant]
RFC 8200, Internet Protocol, Version 6 (IPv6) Specification, Jul. 2017 (Year: 2017). [cited by examiner]
RFC 6554, An IPV6 Routing Header for Source Routes with the Routing Protocol for Low-Power and Lossy Networks (RPL), Mar. 2012 (Year: 2012). [cited by examiner]
Filsfils, C., et al., “Segment Routing Architecture,” IETF, RFC 8402, Jul. 2018, 32 pages. [cited by applicant]
Filsfils, C., et al., “Segment Routing Policy Architecture,” IETF, IETF Draft, draft-ietf-spring-segment-routing-policy-09, Nov. 1, 2020, 37 pages. [cited by applicant]
Bashandy, A., et al., “Segment Routing with the MPLS Data Plane,” IETF, RFC 8660, Dec. 2019, 29 pages. [cited by applicant]
Filsfils, C., et al., “IPV6 Segment Routing Header (SRH),” IETF, RFC 8754, Mar. 2020, 27 pages. [cited by applicant]
Awduche, D., et al., “RSVP-TE: Extensions to RSVP for LSP Tunnels,” IETF, RFC 3209, Dec. 2001, 61 pages. [cited by applicant]
IETF, “Internet Protocol—DARPA Internet Program—Protocol Specification,” IETF, RFC 791, Sep. 1981, 51 pages. [cited by applicant]
Deering, S., “Internet Protocol, Version 6 (IPv6) Specification,” IETF, RFC 2460, Dec. 1998, 39 pages. [cited by applicant]
Katz, D., et al., “IP Router Alert Option,” IETF, RFC 2113, Feb. 1997, 4 pages. [cited by applicant]
Partridge, C., et al., “IPv6 Router Alert Option,” IETF, RFC 2711, Oct. 1999, 6 pages. [cited by applicant]
EP Office Action mailed in corresponding EP application No. 22 184 198.4 mailed on Nov. 21, 2022, 3 pages. [cited by applicant]
First Office Action and Search Report, Chinese Application No. 202210849504.5, Mar. 26, 2024; pp. (9). [cited by applicant]
Notice of Allowance for corresponding European Application No. 22 184 198.4-1215, dated Jul. 1, 2024, 8 pages. [cited by applicant]