IP Library › Granted Patent US 12,316,550
Granted Patent B2
US 12,316,550 · App. 17/560,181 · Granted May 27, 2025

Multi-access management service queueing and reordering techniques

Inventors: Jing Zhu (Portland, OR); Menglei Zhang (Portland, OR)
Assignee: Intel Corporation
H04L47/622H04L47/34H04L49/901H04W28/065H04W76/15
View Patent ↗
Loading inventors, assignments & file history…
Monitor This Case
Get email alerts when status or documents change.
Order Certified Copies
Most orders are placed with the USPTO same day — all within 24 business hours.
Order via The Patent Place →
Pre-filled with this patent's details
Quick Facts
Patent No.
US 12,316,550
App. No.
17/560,181
Granted
May 27, 2025
Kind
B2
Abstract

The present disclosure is related to multi-queue management techniques and packet reordering techniques for inter-radio access technology (RAT) and intra-RAT traffic steering. The multi-queue management and packet reordering techniques may be used in Multi-Access Management Services (MAMS) framework, which is a programmable framework that provides mechanisms for the flexible selection of network paths in a multi-access (MX) communication environment, based on an application's needs. Other embodiments may be described and/or claimed.

Claims (109)

1. A compute node, comprising:

memory circuitry to:

instantiate a ring buffer in a region of the memory circuitry having a fixed size, the ring buffer including a plurality of slots where each slot is assigned a slot index of a plurality of slot indexes, and

instantiate a set of virtual queues, wherein each virtual queue of the set of virtual queues is allocated to one instance of a set of instances and one link of a set of links; and

processor circuitry connected to the memory circuitry, the processor circuitry to execute instructions for multi-queue management, which, when executed are to cause the processor circuitry to:

store a packet to be processed in a subject slot of the plurality of slots, the packet is assigned to a subject instance of the set of instances and a subject link of the set of links, and the subject slot is assigned a subject slot index of the plurality of slot indexes,

store the subject slot index in a subject virtual queue of the set of virtual queues, the subject virtual queue is allocated to the subject instance and the subject link, and

obtain the stored packet from the subject slot using the subject slot index when the packet is scheduled for processing.

2. The compute node of claim 1 , wherein, to process the stored packet, execution of the instructions is to cause the processor circuitry to:

send the stored packet over the subject link.

3. The compute node of claim 1 , wherein, to store the packet to be processed in the subject slot, execution of the instructions is to cause the processor circuitry to:

perform a push function to push the packet into the subject slot.

4. The compute node of claim 3 , wherein, to perform the push function, execution of the instructions is to cause the processor circuitry to:

determine, as the subject slot, an unoccupied slot of the plurality of slots based on a write index;

insert the subject slot index into the subject virtual queue after the packet is pushed into the subject slot;

increment a queue size counter after the packet is pushed into the subject slot, wherein a value of the queue size counter is a number of occupied slots in the plurality of slots;

update an item count parameter of the subject slot based on a total number of virtual queues in the plurality of queues that store the subject slot index; and

update the write index such that the write index references an unoccupied slot of the plurality of slots different than the subject slot.

5. The compute node of claim 4 , wherein, to update the write index, execution of the instructions is to cause the processor circuitry to:

increment the write index; and

determine a modulus of the incremented write index and a total number of slots in the plurality of slots.

6. The compute node of claim 1 , wherein, to obtain the stored packet from the subject slot, execution of the instructions is to cause the processor circuitry to:

perform a pop function to remove the packet from the subject slot.

7. The compute node of claim 6 , wherein, to perform the pop function, execution of the instructions is to cause the processor circuitry to:

obtain the subject slot index from the subject virtual queue;

obtain the packet from the subject slot using the subject slot index; and

remove or delete the subject slot index from the subject virtual queue after identifying or obtaining the subject slot index.

8. The compute node of claim 7 , wherein, to perform the pop function, execution of the instructions is to cause the processor circuitry to:

decrement an item count parameter of the subject virtual queue after removal or deletion of the subject slot index from the subject virtual queue; and

decrement a queue size counter after the packet is popped from the subject slot, wherein a value of the queue size counter is a number of occupied slots in the plurality of slots.

9. The compute node of claim 1 , wherein execution of the instructions is to cause the processor circuitry to:

when all slots of the plurality of slots are occupied, drop one or more slot indexes from one or more virtual queues according to a drop policy.

10. The compute node of claim 1 , wherein:

each instance of the set of instances is one of a thread, a process, an object, a database entity, a user, an application instance, a session, a service, a communication link, or a hardware device; and

each link of the set of links is one of a radio access technology (RAT), a communication link in a multi-access (MX) communication environment operating according to a Multi-Access Management Services (MAMS) framework, an interconnect between two or more hardware elements, an application session, a network session, or a service.

11. The compute node of claim 1 , wherein the compute node is a first compute node, and execution of the instructions is to cause the processor circuitry to:

receive a first packet over a first connection between the first compute node and a second compute node;

receive a second packet over a second connection between the first compute node and the second compute node, wherein the second connection is different than the first connection; and

initiate a packet reordering process to reorder a set of packets including the first and second packets.

12. The compute node of claim 11 , wherein execution of the instructions is to cause the processor circuitry to:

stop the packet reordering process in response to one of receipt of an end marker packet over the first connection, expiration of a reordering timeout (RTO) timer, or when a second sequence number (SN) in the second packet is greater than SNs in other packets in the set of packets regardless of an order in which the first and second packets are received.

13. The compute node of claim 12 , wherein execution of the instructions is to cause the processor circuitry to:

initiate the packet reordering process in response to receipt of the second packet over the second connection; or

initiate the packet reordering process in response to sending a traffic steering request to the second compute node, wherein the traffic steering request is to cause the second compute node to send the end marker packet over the first connection and send the second packet over the second connection.

14. The compute node of claim 12 , wherein the end marker packet includes an indicator to indicate that the packet reordering process is an intra-radio access technology (RAT) packet reordering process or an inter-RAT packet reordering process.

15. A method, comprising:

maintaining a ring buffer in a region of a memory circuitry having a fixed size, the ring buffer including a plurality of slots where each slot is assigned a slot index of a plurality of slot indexes, and

maintaining a set of virtual queues, wherein each virtual queue of the set of virtual queues is allocated to one instance of a set of instances and one link of a set of links;

storing a packet to be processed in a subject slot of the plurality of slots, the packet is assigned to a subject instance of the set of instances and a subject link of the set of links, and the subject slot is assigned a subject slot index of the plurality of slot indexes;

storing the subject slot index in a subject virtual queue of the set of virtual queues, the subject virtual queue is allocated to the subject instance and the subject link; and

obtaining the stored packet from the subject slot using the subject slot index when the packet is scheduled for processing.

16. The method of claim 15 , wherein processing the stored packet comprises:

sending the stored packet over the subject link.

17. The method of claim 15 , wherein storing the packet to be processed in the subject slot comprises:

performing a push function to push the packet into the subject slot.

18. The method of claim 17 , wherein performing the push function comprises:

determining, as the subject slot, an unoccupied slot of the plurality of slots based on a write index;

inserting the subject slot index into the subject virtual queue after the packet is pushed into the subject slot;

incrementing a queue size counter after the packet is pushed into the subject slot, wherein a value of the queue size counter is a number of occupied slots in the plurality of slots;

updating an item count parameter of the subject slot based on a total number of virtual queues in the plurality of queues that store the subject slot index; and

updating the write index such that the write index references an unoccupied slot of the plurality of slots different than the subject slot.

19. The method of claim 18 , wherein updating the write index comprises:

incrementing the write index; and

determining a modulus of the incremented write index and a total number of slots in the plurality of slots.

20. The method of claim 15 , wherein obtaining the stored packet from the subject slot comprises:

performing a pop function to remove the packet from the subject slot.

21. The method of claim 20 , wherein performing the pop function comprises:

obtaining the subject slot index from the subject virtual queue;

obtaining the packet from the subject slot using the subject slot index; and

deleting the subject slot index from the subject virtual queue after identifying or obtaining the subject slot index;

decrementing an item count parameter of the subject virtual queue after removal or deletion of the subject slot index from the subject virtual queue; and

decrementing a queue size counter after the packet is popped from the subject slot, wherein a value of the queue size counter is a number of occupied slots in the plurality of slots.

22. The method of claim 15 , further comprising:

when all slots of the plurality of slots are occupied, dropping one or more slot indexes from one or more virtual queues according to a drop policy.

23. The method of claim 15 , wherein:

each instance of the set of instances is one of a thread, a process, an object, a database entity, a user, an application instance, a session, a service, a communication link, or a hardware device; and

each link of the set of links is one of a radio access technology (RAT), a communication link in a multi-access (MX) communication environment operating according to a Multi-Access Management Services (MAMS) framework, an interconnect between two or more hardware elements, an application session, a network session, or a service.

24. One or more non-transitory computer readable media (NTCRM) comprising instructions for performing multi-queue management, wherein execution of the instructions by one or more processors of a compute node is to cause the compute node to:

store a set of packets to be processed in respective slots of plurality of slots, wherein the plurality of slots form a ring buffer that is implemented in a memory region having a fixed size, the plurality of slots are assigned respective slot indexes of a plurality of slot indexes, and the respective slot indexes reference a memory location of a corresponding slot of the plurality of slots;

push the respective slot indexes into a plurality of virtual queues, wherein each virtual queue of the plurality of virtual queues is allocated to an instance of a set of instances and a link of a set of links;

pop a set of the respective slot indexes from one or more virtual queues of the plurality of virtual queues; and

obtain a subset of the stored packets from their respective slots using the popped slot indexes.

25. The one or more NTCRM of claim 24 , wherein, to store the packets to be processed in the respective slots, execution of the instructions is to cause the compute node to:

determine, for each packet of the set of packets, an unoccupied slot of the plurality of slots based on a value of a write index.

26. The one or more NTCRM of claim 25 , wherein, to push the respective slot indexes into the plurality of virtual queues, execution of the instructions is to cause the compute node to, for an individual packet of the set of packets:

insert, into at least one virtual queue of the plurality of virtual queues, a slot index corresponding to an individual slot of the of plurality of slots in which the individual packet is stored;

increment a queue size counter after the individual packet is stored in the individual slot, wherein a value of the queue size counter is a number of occupied slots in the plurality of slots;

update an item count parameter of the individual slot based on a number of virtual queues in the plurality of queues that store the slot index; and

update the write index such that the write index references an unoccupied slot of the plurality of slots different than the individual slot.

27. The one or more NTCRM of claim 25 , wherein, to pop the set of the respective slot indexes from the one or more virtual queues, execution of the instructions is to cause the compute node to:

obtain each slot index of the set of the respective slot indexes from the one or more virtual queues;

delete each obtained slot index from a virtual queue of the one or more virtual queues from which they are obtained;

decrement an item count parameter of the virtual queue after the deletion of each obtained slot index; and

decrement a queue size counter after the packet is obtained from its respective slot.

28. The one or more NTCRM of claim 24 , wherein:

each instance of the set of instances is one of a thread, a process, an object, a database entity, a user, an application instance, a session, a service, a communication link, or a hardware device; and

each link of the set of links is one of a radio access technology (RAT), a communication link in a multi-access (MX) communication environment operating according to a Multi-Access Management Services (MAMS) framework, an interconnect between two or more hardware elements, an application session, a network session, or a service.

29. The one or more NTCRM of claim 24 , wherein execution of the instructions is to cause the compute node to:

receive, over a first link of the set of links, a subset of packets of the set of packets;

receive, over a second link of the set of links, at least one packet of a set of packets not in the subset;

initiate a packet reordering process to reorder the set of packets using the respective slot indexes.

30. The one or more NTCRM of claim 29 , wherein execution of the instructions is to cause the compute node to:

stop the packet reordering process in response to one of receipt of:

an end marker packet over the first link,

expiration of a reordering timeout (RTO) timer, or

when a second sequence number (SN) in the second packet is greater than SNs in other packets in the set of packets regardless of an order in which the first and second packets are received; and

initiate the packet reordering process in response to one of:

receipt of the second packet over the second link, or

transmission of a traffic steering request to another compute node, wherein the traffic steering request is to cause the other compute node to send the end marker packet over the first link and send the second packet over the second link.

Assignments (1)
ASSIGNMENT OF ASSIGNOR'S INTEREST Recorded Dec 22, 2021
From: ZHU, JING; ZHANG, MENGLEI
To: INTEL CORPORATION
Reel/Frame 058466/0370 →
Continuity (1)
Related Publication 20220116334A1 · Apr 14, 2022
References Cited (157)
US 6957212B2 · Peng · 2005 [cited by applicant]
US 7243354B1 · Chhabra · 2007 [cited by examiner]
US 8949501B1 · Akhter et al. · 2015 [cited by applicant]
US 9398121B1 · Brandwine · 2016 [cited by applicant]
US 20030091054A1 · Futenma · 2003 [cited by applicant]
US 20060168336A1 · Koyanagi · 2006 [cited by applicant]
US 20100202323A1 · Nishida · 2010 [cited by applicant]
US 20130246672A1 · Saputra · 2013 [cited by applicant]
US 20140307593A1 · Zhao et al. · 2014 [cited by applicant]
US 20150029879A1 · Chou et al. · 2015 [cited by applicant]
US 20150078359A1 · Scahill et al. · 2015 [cited by applicant]
US 20150215835A1 · Sirotkin · 2015 [cited by applicant]
US 20160112896A1 · Karampatsis · 2016 [cited by applicant]
US 20160270145A1 · Srinivasa Gopalan et al. · 2016 [cited by applicant]
US 20160381491A1 · Watfa et al. · 2016 [cited by applicant]
US 20170019830A1 · Lindoff et al. · 2017 [cited by applicant]
US 20170093541A1 · Pan et al. · 2017 [cited by applicant]
US 20180027508A1 · Tanaka · 2018 [cited by applicant]
US 20180077022A1 · Van Oost et al. · 2018 [cited by applicant]
US 20180092085A1 · Shaheen et al. · 2018 [cited by applicant]
US 20180018385A1 · Sabella et al. · 2018 [cited by applicant]
US 20180270742A1 · Bergstrom et al. · 2018 [cited by applicant]
US 20190036841A1 · Nolan · 2019 [cited by applicant]
US 20190306749A1 · Bergstrom et al. · 2019 [cited by applicant]
US 20190306752A1 · Lai · 2019 [cited by applicant]
US 20190394833A1 · Talebi Fard et al. · 2019 [cited by applicant]
US 20200045612A1 · Stauffer et al. · 2020 [cited by applicant]
US 20200053018A1 · White et al. · 2020 [cited by applicant]
US 20200178196A1 · Wang et al. · 2020 [cited by applicant]
US 20210051104A1 · He · 2021 [cited by applicant]
US 20210058936A1 · Gordaychik · 2021 [cited by applicant]
US 20210100047A1 · Chiba et al. · 2021 [cited by applicant]
US 20210144590A1 · Li · 2021 [cited by applicant]
US 20210211914A1 · De La Oliva et al. · 2021 [cited by applicant]
US 20210306900A1 · Mehta · 2021 [cited by applicant]
US 20210385865A1 · Mueck · 2021 [cited by applicant]
US 20210400537A1 · Zhang et al. · 2021 [cited by applicant]
US 20210409335A1 · Zhu et al. · 2021 [cited by applicant]
US 20220155975A1 · Nortman · 2022 [cited by examiner]
US 20220191733A1 · Ali et al. · 2022 [cited by applicant]
US 20230056442A1 · Ly et al. · 2023 [cited by applicant]
US 20230189368A1 · Zhou · 2023 [cited by applicant]
US 20230276483A1 · Xu et al. · 2023 [cited by applicant]
EP 3414932A1 · 2018 [cited by applicant]
WO WO2015152787A1 · 2015 [cited by applicant]
WO WO2017139699A1 · 2017 [cited by applicant]
WO WO2017189176A2 · 2017 [cited by applicant]
WO WO2019076440A1 · 2019 [cited by applicant]
WO WO2019192528A1 · 2019 [cited by applicant]
WO WO2020232404A1 · 2020 [cited by applicant]
WO WO2021257974A1 · 2021 [cited by applicant]
WO WO2022005917A1 · 2022 [cited by applicant]
WO WO2022005918A1 · 2022 [cited by applicant]
Nikc McKeown et al., “Tiny Tera: A Packet Switch Core”, IEEE Micro, IEEE Service Center, Los Alamitos, CA, US deel 17, nr.1, (Jan. 1, 1997), 8 pages. [cited by applicant]
S. Kanugovi et al., “Multi-Access Management Services (MAMS)”, rtc8743.txt, Multi-Access Management Services (MAMS); RFC8743.TXT, Internet Engineering Task Force, IETF; Standard, Internei Society (ISOC) 4, Rue Des Falai… [cited by applicant]
International Search Report and Written Opinion mailed Oct. 8, 2021 for International Patent Application No. PCT/US2021/039253, 12 pages. [cited by applicant]
“3rd Generation Partnership Project; Technical Specification Group Services and System Aspects; Study on access traffic steering, switch and splitting support in the 5G system architecture (Release 16)”, 3GPP TR 23.793 … [cited by applicant]
“3rd Generation Partnership Project; Technical Specification Group Services and System Aspects; Study on Access Traffic Steering, Switch and Splitting support in the 5G system architecture Phase 2 (Release 17)”, 3GPP TR… [cited by applicant]
International Preliminary Report on Patentability mailed Jan. 12, 2023 for International Patent Application No. PCT/ JS2021/039253, 7 pages. [cited by applicant]
International Search Report and Written Opinion mailed Nov. 19, 2021 for International Patent Application No. PCT/US2021/039252, 13 pages. [cited by applicant]
International Preliminary Report on Patentability mailed Jan. 12, 2023 for International Patent Application No. PCT/ US2021/039252, 8 pages. [cited by applicant]
U.S. Appl. No. 63/025,086 “Dynamic Traffic Management in Next Generation Multi-Access Management Service Frameworks”, filed May 14, 2020, 78 pages. [cited by applicant]
U.S. Appl. No. 17/922,947 “RAN-Aware Traffic Distribution Rules and RAN Measurements for Enhanced Access Traffic Steering Switching and Splitting”, filed Nov. 2, 2022, 92 pages. [cited by applicant]
U.S. Appl. No. 17/925,430 “Wireless Local Area Network Enhancements for Access Traffic Steering Switching Splitting”, filed Nov. 15, 2022, 64 pages. [cited by applicant]
“3rd Generation Partnership Project; Technical Specification Group Services and System Aspects; System architecture for the 5G System (5GS); Stage 2 (Release 15)”, 3GPP TS 23.501 V15.9.0 (Mar. 27, 2020), 248 pages. [cited by applicant]
A. Ford et al., “RFC 8684 TCP Extensions for Multipath Operation with Multiple Addresses”: http://tools.ietf.org/html/draft-ietf-mptcp-multiaddressed-09, 6 pages (Mar. 2020). [cited by applicant]
“3rd Generation Partnership Project; Technical Specification Group Services and System Aspects; Management and orchestration; 5G performance measurements (Release 16)”, 3GPP TS 28.552 V16.5.0 (Mar. 27, 2020), 173 pages. [cited by applicant]
“3rd Generation Partnership Project; Technical Specification Group Radio Access Network; Evolved Universal Terrestrial Radio Access (E-UTRA); Layer 2—Measurements (Release 15)”, 3GPP TS 36.314 V15.2.0 (Jan. 11, 2019), 2… [cited by applicant]
“IEEE Standard for Information technology—Telecommunications and information exchange between systems Local and metropolitan area networks—Specific requirements—Part 11: Wireless LAN Medium Access Control (MAC) and Phys… [cited by applicant]
Wi-Fi Alliance, “Wi-Fi Agile Multiband Technical Specification”, Version 1.5, 32 pages (2020). [cited by applicant]
Wi-Fi Alliance, “Optimized Connectivity Specification”, Version 1.1.6, 26 pages (2020). [cited by applicant]
Sangeetha Bangolae et al., “Performance Study of Fast BSS Transition using IEEE 802.11r”, Proceedings of the 2006 Int'l Conference on Wireless Comm. and Mobile Computing (IWCMC '06), pp. 737-742 (Jul. 3, 2006), https://… [cited by applicant]
“Wi-Fi Roaming Aggressiveness Setting”, Intel Corporation, Article ID 000005546, 2 pages (Oct. 28, 2021). [cited by applicant]
Yordan, “Oppo and vivo announce Dual Wi-Fi for their flagships”, GSMArena.com, 3 pages (Jul. 18, 2019), https://www.gsmarena.com/oppo_vivo_dual_wifi-news-38203.php. [cited by applicant]
Q. De Coninck et al., “Multipath Extensions for QUIC (MP-QUIC)”, IETF, draft-deconinck-quic-multipath-07, 36 pages (May 3, 2021), https://datatracker.ietf.org/doc/html/draft-deconinck-quic-multipath-07. [cited by applicant]
J. Zhu et al., “Generic Multi-Access (GMA) Encapsulation Protocol”, IETF, draft-zhu-intarea-gma-14, 17 pages (Nov. 24, 2021), https://datatracker.ietf.org/doc/html/draft-zhu-intarea-gma-14. [cited by applicant]
J. Zhu et al., “User-Plane Protocols for Multiple Access Management Service”, IETF, draft-zhu-intarea-mams-user-protocol-09, 8 pages (Mar. 4, 2020). [cited by applicant]
“3rd Generation Partnership Project; Technical Specification Group Core Network and Terminals; 5G System; Access Traffic Steering, Switching and Splitting (ATSSS); Stage 3 (Release 17)”, 3GPP TS 24.193 v17.2.0 (Sep. 24,… [cited by applicant]
“3rd Generation Partnership Project; Technical Specification Group Core Network and Terminals; Access Network Discovery and Selection Function (ANDSF) Management Object (MO) (Release 16)”, 3GPP TS 24.312 v16.0.0 (Jul. 9… [cited by applicant]
“3rd Generation Partnership Project; Technical Specification Group Radio Access Network; Evolved Universal Terrestrial Radio Access (E-UTRA); LTE/WLAN Radio Level Integration Using IPsec Tunnel (LWIP) encapsulation; Pro… [cited by applicant]
International Search Report and Written Opinion mailed Aug. 31, 2020 for International Patent Application No. PCT/US2020/033261, 14 pages. [cited by applicant]
International Preliminary Report on Patentability mailed Nov. 25, 2021 for International Patent Application No. PCT/US2020/033261, 10 pages. [cited by applicant]
“3rd Generation Partnership Project; Technical Specification Group Services and System Aspects; Study on access traffic steering, switch and splitting support in the 5G system architecture (Release 16)”, 3GPP TR 23.793 … [cited by applicant]
S. Kanugovi et al., “Multiple Access Management Services”, draft-kanugovi-intarea-mams-framework-03, Internet Engineering Task Force (IETF), 156 pages (Feb. 28, 2019), https://tools.ietf.org/search/draft-kanugovi-intare… [cited by applicant]
S. Kanugovi et al., Multiple Access Management Services, draft-kanugovi-intarea-mams-framework-04, Internet Engineering Task Force (IETF), 122 pages (May 31, 2019), https://datatracker.ietf.org/doc/html/draft-kanugovi-i… [cited by applicant]
J. Zhu et al., “User-Plane Protocols for Multiple Access Management Service”, draft-zhu-intarea-mams-user-protocol-07, Internet Engineering Task Force (IETF), 14 pages (Apr. 3, 2019), https://datatracker.ietf.org/doc/ht… [cited by applicant]
“3rd Generation Partnership Project; Technical Specification Group Services and System Aspects; System Architecture for the 5G System; Stage 2 (Release 16)”, 3GPP TS 23.501 v16.1.0, 368 pages (Jun. 11, 2019). [cited by applicant]
“3rd Generation Partnership Project; Technical Specification Group Core Network and Terminals; 5G System; Access and Mobility Management Services; Stage 3 (Release 16)”, 3GPP TS 29.518 V16.0.0, 199 pages (Jun. 13, 2019). [cited by applicant]
“Multi-access Edge Computing (MEC); Framework and Reference Architecture”, ETSI GS MEC 003 V2.1.1, 21 pages (Jan. 2019). [cited by applicant]
“Multi-access Edge Computing (MEC); Phase 2: Use Cases and Requirements”, ETSI GS MEC 002 V2.1.1, 66 pages (Oct. 2018). [cited by applicant]
“Mobile Edge Computing(MEC); Bandwidth Management API”, ETSI GS MEC 015 V1.1.1, 20 pages (Oct. 2017). [cited by applicant]
“3rd Generation Partnership Project; Technical Specification Group Core Network and Terminals; 5G System; Network Exposure Function Northbound APIs; Stage 3 (Release 16)”, 3GPP TS 29.522 V16.0.0, 43 pages (Jun. 18, 2019… [cited by applicant]
“Multi-access Edge Computing (MEC); General principles for MEC Service APIs Disclaimer”, ETSI GS MEC 009 V2.1.1, 64 pages (Jan. 2019). [cited by applicant]
“3rd Generation Partnership Project; Technical Specification Group Services and System Aspects; System Architecture for the 5G System; Stage 2 (Release 16)” 3GPP TS 23.501 v16.0.2, 317 pages (Apr. 1, 2019). [cited by applicant]
“3rd Generation Partnership Project; Technical Specification Group Core Network and Terminals; 5G System; Access and Mobility Management Services; Stage 3 (Release 15)”, 3GPP TS 29.518 V15.3.0, 195 pages (Mar. 24, 2019). [cited by applicant]
“Mobile Edge Computing (MEC); Radio Network Information API”, ETSI GS MEC 012 V1.1.1, 57 pages (Jul. 2017). [cited by applicant]
International Preliminary Report on Patentability mailed Oct. 13, 2022 for International Patent Application PCT/US2020/066969, 8 pages. [cited by applicant]
Extended European Search Report issued Jun. 14, 2024 for EP Application No. 21825017.3, 4 pages. [cited by applicant]
Deutsche Bahn AG, “Exemplary Mapping of 3GPP Building Blocks to FRMCS Logical Architecture Draft,” ETSI Draft RT(19)075028r3, ETSI, Dec. 12, 2019, 13 pages. [cited by applicant]
Office Action mailed Jun. 21, 2024 for U.S. Appl. No. 17/437,711, 96 pages. [cited by applicant]
Notice of Allowance mailed Aug. 20, 2024 for U.S. Appl. No. 17/469,331, 21 pages. [cited by applicant]
Notice of Allowance mailed Aug. 2, 2024 for U.S. Appl. No. 17/923,170, 71 pages. [cited by applicant]
Office Action mailed Sep. 18, 2024 for U.S. Appl. No. 17/797,661, 72 pages. [cited by applicant]
Extended European Search Report mailed May 10, 2023 for European Patent Application No. 20806061.6, 11 pages. [cited by applicant]
S. Kanugovi Nokia e al., “Multiple Access Management Services; Draft-Kanugovi-intarea-mams-fraaework-03”, (Feb. 28, 2019), 141 pages. [cited by applicant]
3GPP, “3rd Generation Partnership Project; Technical Specification Group Services and System Aspects; Study on access traffic steering, switch and splitting support in the 5G system architecture (Release 16)”, 3GPP TR 2… [cited by applicant]
International Preliminary Report on Patentability mailed Dec. 29, 2022 for International Patent Application PCT/US2021/038063, 10 pages. [cited by applicant]
Extended European Search Report mailed Apr. 14, 2023 for European Patent Application No. 22203400.1, 13 pages. [cited by applicant]
Nádas et al., “Per Packet Value: A Practical Concept for Network Resource Sharing”, 2016 IEEE Global Communications Conference (GLOBECOM), pp. 1-7 (Dec. 4, 2016). [cited by applicant]
Laki et al., “Take your own share of the PIE”, Proceedings of the Applied Networking Research Workshop, pp. 27-32 (Jul. 15, 2017). [cited by applicant]
Nádas et al., “Towards a congestion control-independent core-stateless AQM”, Proceedings of the Applied Networking Research Workshop, pp. 84-90 (Jul. 16, 2018). [cited by applicant]
Laki et al., “Scalable Per Subscriber QoS with Core-Stateless Scheduling”, ACM SIGCOMM Industrial Demos, 2 pages (2018). [cited by applicant]
Nádas et al., “Stateless resource sharing in networks with multi-layer virtualization”, 2019 IEEE International Conference on Communications (ICC), pp. 1-7 (May 20, 2019). [cited by applicant]
Nádas et al., “Towards core-stateless fairness on multiple timescales”, Proceedings of the Applied Networking Research Workshop, pp. 30-36 (Jul. 22, 2019). [cited by applicant]
Fejes et al., “Decoupling delay and resource sharing targets with efficient core-stateless AQM”, Proceedings of the ACM SIGCOMM 2019 Conference Posters and Demos, pp. 128-130 (Aug. 19, 2019). [cited by applicant]
Fejes et al., “Who will Save the Internet from the Congestion Control Revolution?”, Proceedings of the 2019 Workshop on Buffer Sizing, Stanford University, 6 pages (2019), http://ppv.elte.hu/buffer-sizing/. [cited by applicant]
Fejes et al., “On the Incompatibility of Scalable Congestion Controls over the Internet”, 2020 IFIP Networking Conference (Networking), IEEE, pp. 749-754 (Jun. 22, 2020), http://ppv.elte.hu/scalable-cc-comp/. [cited by applicant]
Nádas et al., A congestion control independent L4S scheduler. InProceedings of the Applied Networking Research Workshop, pp. 45-51 (Jul. 27, 2020). [cited by applicant]
Laki et al., “Core-Stateless Forwarding With QoS Revisited: Decoupling Delay and Bandwidth Requirements”, IEEE/ACM Transactions on Networking 29, No. 2, pp. 503-516 (Dec. 9, 2020). [cited by applicant]
Fejes et al., “A Core-Stateless L4S Scheduler for P4-enabled hardware switches with emulated HQoS”, IEEE INFOCOM 2021 Demo (Virtual), 2 p. (2021), http://ppv.elte.hu/ic21/. [cited by applicant]
Bemten et al., “Network Calculus: A Comprehensive Guide”, Technical Report No. 201603, 57 pages (Oct. 8, 2016). [cited by applicant]
Charny et al., “Delay Bounds in a Network with Aggregate Scheduling”, International Workshop on Quality of Future Internet Services 2000 (QoFIS'2000), Springer Berlin, Heidelberg, pp. 1-13 (Sep. 25, 2000). [cited by applicant]
Zhu et al., “Generic Multi-Access (GMA) Encapsulation Protocol”, draft-zhu-intarea-gma-07, 13 pages (May 14, 2020). [cited by applicant]
Feng et al., “The BLUE active queue management algorithms”, 19 pages, (Sep. 2002), http://www.researchgate.net/publication/3334841. [cited by applicant]
Mustafa Maad Hamdi et al., “A review on Queue Management Algorithms in Large Networks”, IOP Conference Series: Materials Science and Engineering, vol. 1076, No. 1, p. 012034, 13 pages (Feb. 1, 2021), https://iopscience.… [cited by applicant]
Nichols et al., “Definition of the Differentiated Services Field (DS Field) in the IPV4 and IPV6 Headers”, IETF RFC 2474, 20 pages (Dec. 1998). [cited by applicant]
Ramakrishnan et al., “The Addition of Explicit Congestion Notification (ECN) to IP”, IETF RFC 3168, 63 pages (Sep. 2001). [cited by applicant]
Amante et al., “IPv6 Flow Label Specification”, IETF RFC 6437, 15 pages (Nov. 2011). [cited by applicant]
D. Black, “Relaxing Restrictions on Explicit Congestion Notification (ECN) Experimentation”, IETF RFC 8311, 20 pages (Jan. 2018). [cited by applicant]
G. Fairhurst, “Update to IANA Registration Procedures for Pool 3 Values in the Differentiated Services Field Codepoints (DSCP) Registry”, IETF RFC 8436, 7 pages (Aug. 2018). [cited by applicant]
Zhu et al., “Improving QoE for Skype Video Call in Mobile Broadband Network”, 2012 IEEE Global Communications Conference (GLOBECOM), pp. 1938-1943 (Dec. 3, 2012). [cited by applicant]
Kanugovi et al., “Control Plane Protocols and Procedures for Multiple Access Management Services”, IETF, draft-zhu-intarea-mams-control-protocol-02 (Jul. 3, 2017), 31 pages. [cited by applicant]
Li et al., “Multipath Transmission for Internet: A Survey”, 39 p. IEEE Communications Surveys & Tutorials, vol. 18, No. 4, Fourth Quarter 2016, pp. 2887-2925 (Jun. 29, 2016). [cited by applicant]
“TCP Keep-Alives” in Braden, “Requirements for Internet Hosts—Communication Layers”, IETF RFC 1122, section 4.2.3.6, pp. 101-102 (Oct. 1, 1989), 2 pages. [cited by applicant]
J. Zhu et al., “Generic Multi-Access (GMA) Encapsulation Protocol draft-zhu-intarea-gma-07”, INTAREA/Network Working Group Draft, 13 pages (May 14, 2020), https://datatracker.ietf.org/doc/html/draft-zhu-intarea-gma-07. [cited by applicant]
S. Kanugovi et al., “Multi-Access Management Services (Mams)”, IETF RFC 8743, 143 pages (Mar. 2020), https://www.rfc-editor.org/rfc/rfc8743.html. [cited by applicant]
International Search Report and Written Opinion mailed Oct. 6, 2021 for Int'l App. No. PCT/US2021/038063, 14 pages. [cited by applicant]
“3GPP; TSG SA; Study on enhanced support of Industrial Internet of Things (IIoT) in 5G System (Release 17)”, 3GPP TR 23.700-20 V0.3.0 (Jan. 28, 2020). [cited by applicant]
Han-Chuan Hsieh et al., “5G Virtualized Multi-access Edge Computing Platform for IoT Applications”, Journal of Network and Computer Applications, vol. 115, pp. 94-102 (May 10, 2018). [cited by applicant]
Boyd et al., “Convex Optimization”, Cambridge University Press, Cambridge, UK, ISBN: 978-0-521-83378-3, 730 pages (Mar. 2004). [cited by applicant]
“Multi-access Edge Computing (MEC); Radio Network Information API”, ETSI GS MEC 012 V2.1.1, 66 pages (Dec. 2019). [cited by applicant]
Ford et al., “TCP Extensions for Multipath Operation with Multiple Addresses”, Internet Engineering Task Force (IETF), Internet Draft, draft-ietf-mptcp-multiaddressed-09, 62 pages (Jun. 6, 2012), https://datatracker.iet… [cited by applicant]
“Intel® Network Edge Virtualization (NEV) Software Development Kit”, Intel Corp., Intel® Network Edge Virtualization Product Brief, 3 pages (Aug. 16, 2015), https://networkbuilders.intel.com/docs/Intel_Wireless_Product_… [cited by applicant]
“Simplify Application Development for the Network Edge”, Intel Corp., Service Provider NFV, White Paper, 5 pages (Sep. 26, 2018), https://www.intel.com/content/dam/www/public/us/en/documents/white-papers/nev-sdk-white-p… [cited by applicant]
“O-RAN Architecture Description”, O-RAN Alliance, O-RAN-WG1-O-RAN Architecture Description, v01.00.00, 24 pages (Feb. 2020). [cited by applicant]
“O-RAN Working Group 2, AI/ML workflow description and requirements”, O-RAN Alliance, ORAN-WG2.AIML, v01.00, 34 pages (Dec. 2019). [cited by applicant]
Singh et al., “Optimal Traffic Aggregation in Multi-RAT Heterogeneous Wireless Networks”, IEEE ICC2016—Workshops: W09—Workshop on 5G RAN Design, 6 pages (Mar. 7, 2016). [cited by applicant]
Zhu et al., “Generic Multi-Access (GMA) Convergence Encapsulation Protocols”, INTAREA/Network Working Group, Internet Draft, draft-zhu-intarea-gma-04, 10 pages (Sep. 30, 2019), https://datatracker.ietf.org/doc/pdf/draft… [cited by applicant]
Zhu et al., “Generic Multi-Access (GMA) Convergence Encapsulation Protocols”, INTAREA/Network Working Group, Internet Draft, draft-zhu-intarea-gma-05, 12 pages (Dec. 16, 2019), https://datatracker.ietf.org/doc/pdf/draft… [cited by applicant]
International Search Report and Written Opinion mailed Apr. 15, 2021 for International Patent Application PCT/US2020/066969, 13 pages. [cited by applicant]
Office Action mailed Mar. 6, 2024 for U.S. Appl. No. 17/469,331, 96 pages. [cited by applicant]
G. Dommety, “Key and Sequence No. Extensions to GRE”, Internet Engineering Task Force (IETF) RFC 2890, 7 pages (Sep. 2000). [cited by applicant]
A. Huttunen et al., “UDP Encapsulation of IPsec ESP Packets”, Internet Engineering Task Force (IETF) RFC 3984, 15 pages (Jan. 2005). [cited by applicant]
A. Ford et al., “TCP Extensions for Multipath Operation with Multiple Addresses”, Internet Engineering Task Force (IETF) RFC 6824, 64 pages (Jan. 2013). [cited by applicant]
N. Leymann et al., “Huawei's GRE Tunnel Bonding Protocol”, Internet Engineering Task Force (IETF) RFC 81557, 44 pages (May 2017). [cited by applicant]
S. Kanugovi et al., “Multi-Access Management Services (MAMS)”, Internet Engineering Task Force (IETF) RFC 8743, 143 pages (Mar. 2020). [cited by applicant]
J. Zhu et al., “Generic Multi-Access (GMA) Encapsulation Protocol”, Internet Engineering Task Force (IETF) RFC 9188, 15 pages (Feb. 2022). [cited by applicant]