IP Library › Granted Patent US 12,425,579
Granted Patent B2
US 12,425,579 · App. 18/342,023 · Granted Sep 23, 2025

Method, an apparatus and a computer program product for implementing gradual decoding refresh

Inventor: Miska Matias Hannuksela (Tampere, FI)
Assignee: Nokia Technologies Oy
H04N19/107H04N19/11H04N19/136H04N19/172H04N19/174H04N19/188H04N19/33H04N19/85
View Patent ↗
Loading inventors, assignments & file history…
Monitor This Case
Get email alerts when status or documents change.
Order Certified Copies
Most orders are placed with the USPTO same day — all within 24 business hours.
Order via The Patent Place →
Pre-filled with this patent's details
Quick Facts
Patent No.
US 12,425,579
App. No.
18/342,023
Granted
Sep 23, 2025
Kind
B2
Abstract

The embodiments relate to a method comprising receiving an encoded video comprising a GDR picture and recovering pictures following the GDR picture in decoding order; decoding information that a slice-based GDR is in use, wherein each of the GDR picture and the recovering pictures comprises a first set of slices comprising a clean area and a second set of slices comprising rest of the picture; relabeling the GDR picture as an intra-coded random access point picture in a modified bitstream; including only the first set of slices of the GDR picture and the recovering pictures into the modified bitstream; decoding information on a picture width and height of each of the GDR picture and the recovering pictures; modifying the picture width and height to exclude the second set of slices; and including the modified information on the picture width and height to the modified bitstream.

Claims (61)

1. An apparatus comprising:

at least one processor; and

at least one memory including computer program code;

wherein the at least one memory and the computer program code are configured to, with the at least one processor, cause the apparatus at least to:

receive an encoded video bitstream comprising a gradual decoding refresh picture and recovering pictures following the gradual decoding refresh picture in decoding order;

decode information that a slice-based gradual decoding refresh is in use, wherein each of the gradual decoding refresh picture and the recovering pictures comprises a first set of slices comprising a clean area and a second set of slices comprising rest of the picture; relabel the gradual decoding refresh picture as an intra-coded random access point picture in a modified bitstream;

include only the first set of slices of the gradual decoding refresh picture and the recovering pictures into the modified bitstream;

decode information on a picture width and a picture height of each of the gradual decoding refresh picture and the recovering pictures;

modify the picture width and the picture height to exclude the second set of slices;

include the modified information on the picture width and the picture height to the modified bitstream;

decode information on scaling window offsets relative to the decoded picture width and picture height of each of the gradual decoding refresh picture and the recovering pictures;

derive a scaling window from the scaling window offsets of each of the gradual decoding refresh picture and the recovering pictures;

modify the scaling window offsets of each of the gradual decoding refresh picture to be relative to the modified picture width and height so that the scaling window derived from the modified scaling window offsets remains unchanged in each of the gradual decoding refresh picture and the recovering pictures; and

include the modified information on the scaling window offsets to the modified bitstream.

2. The apparatus according to claim 1 , wherein the at least one memory and the computer program code are further configured to, with the at least one processor, cause the apparatus at least to:

rewrite network abstraction layer unit type values of the first set of slices of the gradual decoding refresh picture to indicate an instantaneous decoding refresh picture in the modified bitstream.

3. The apparatus according to claim 1 , wherein the at least one memory and the computer program code are further configured to, with the at least one processor, cause the apparatus at least to:

include indications of a picture width and a picture height of a recovery point picture within the intra-coded random access point picture in the modified bitstream.

4. The apparatus according to claim 1 , wherein the at least one memory and the computer program code are further configured to, with the at least one processor, cause the apparatus at least to:

include an indication of a gradually increased picture area within the intra-coded random access point picture in the modified bitstream.

5. The apparatus according to claim 1 , wherein the at least one memory and the computer program code are further configured to, with the at least one processor, cause the apparatus at least to:

receive a decoder refresh command; and

perform modification of the video bitstream to the modified bitstream in response to the received decoder refresh command, and omit modification of the video bitstream otherwise.

6. A method, comprising:

receiving an encoded video bitstream comprising a gradual decoding refresh picture and recovering pictures following the gradual decoding refresh picture in decoding order;

decoding information that a slice-based gradual decoding refresh is in use, wherein each of the gradual decoding refresh picture and the recovering pictures comprises a first set of slices comprising a clean area and a second set of slices comprising rest of the picture;

relabeling the gradual decoding refresh picture as an intra-coded random access point picture in a modified bitstream; including only the first set of slices of the gradual decoding refresh picture and the recovering pictures into the modified bitstream;

decoding information on a picture width and a picture height of each of the gradual decoding refresh picture and the recovering pictures;

modifying the picture width and the picture height to exclude the second set of slices;

including the modified information on the picture width and the picture height to the modified bitstream;

decoding information on scaling window offsets relative to the decoded picture width and picture height of each of the gradual decoding refresh picture and the recovering pictures; deriving a scaling window from the scaling window offsets of each of the gradual decoding refresh picture and the recovering pictures;

modifying the scaling window offsets of each of the gradual decoding refresh picture to be relative to the modified picture width and height so that the scaling window derived from the modified scaling window offsets remains unchanged in each of the gradual decoding refresh picture and the recovering pictures;

including the modified information on the scaling window offsets to the modified bitstream.

7. The method according to claim 6 , further comprising:

rewriting network abstraction layer unit type values of the first set of slices of the gradual decoding refresh picture to indicate an instantaneous decoding refresh picture in the modified bitstream.

8. The method according to claim 6 , further comprising:

including indications of a picture width and a picture height of a recovery point picture within the intra-coded random access point picture in the modified bitstream.

9. The method according to claim 6 , further comprising:

including an indication of a gradually increased picture area within the intra-coded random access point picture in the modified bitstream.

10. The method according to claim 6 , further comprising:

receiving a decoder refresh command; performing modification of the video bitstream to the modified bitstream in response to the received decoder refresh command, and omitting modification of the video bitstream otherwise.

11. A non-transitory computer readable medium comprising program instructions which when executed by an apparatus, cause the apparatus at least to:

receive an encoded video bitstream comprising a gradual decoding refresh picture and recover pictures following the gradual decoding refresh picture in decoding order;

decode information that a slice-based gradual decoding refresh is in use, wherein each of the gradual decoding refresh picture and the recovering pictures comprises a first set of slices comprising a clean area and a second set of slices comprising rest of the picture;

relabel the gradual decoding refresh picture as an intra-coded random access point picture in a modified bitstream;

include only the first set of slices of the gradual decoding refresh picture and the recovering pictures into the modified bitstream;

decode information on a picture width and a picture height of each of the gradual decoding refresh picture and the recovering pictures;

modify the picture width and the picture height to exclude the second set of slices;

include the modified information on the picture width and the picture height to the modified bitstream;

decode information on scaling window offsets relative to the decoded picture width and picture height of each of the gradual decoding refresh picture and the recovering pictures;

derive a scaling window from the scaling window offsets of each of the gradual decoding refresh picture and the recovering pictures;

modify the scaling window offsets of each of the gradual decoding refresh picture to be relative to the modified picture width and height so that the scaling window derived from the modified scaling window offsets remains unchanged in each of the gradual decoding refresh picture and the recovering pictures; and

include the modified information on the scaling window offsets to the modified bitstream.

12. The non-transitory computer readable medium according to claim 11 , wherein the program instructions which when executed by an apparatus, further cause the apparatus at least to: rewrite network abstraction layer unit type values of the first set of slices of the gradual decoding refresh picture to indicate an instantaneous decoding refresh picture in the modified bitstream.

13. The non-transitory computer readable medium according to claim 11 , wherein the program instructions which when executed by an apparatus, further cause the apparatus at least to:

include indications of a picture width and a picture height of a recovery point picture within the intra-coded random access point picture in the modified bitstream.

14. The non-transitory computer readable medium according to claim 11 , wherein the program instructions which when executed by an apparatus, further cause the apparatus at least to:

include an indication of a gradually increased picture area within the intra-coded random access point picture in the modified bitstream.

15. The non-transitory computer readable medium according to claim 11 , wherein the program instructions which when executed by an apparatus, further cause the apparatus at least to:

receive a decoder refresh command;

perform modification of the video bitstream to the modified bitstream in response to the received decoder refresh command, and omit modification of the video bitstream otherwise.

Assignments (1)
ASSIGNMENT OF ASSIGNOR'S INTEREST Recorded Jul 28, 2023
From: MATIAS HANNUKSELA, MISKA
To: NOKIA TECHNOLOGIES OY
Reel/Frame 064418/0437 →
Continuity (1)
Related Publication 20240007619A1 · Jan 4, 2024
References Cited (35)
US 20140301464A1 · Wu et al. · 2014 [cited by applicant]
US 20180176603A1 · Fujimoto · 2018 [cited by applicant]
US 20200177923A1 · Chen et al. · 2020 [cited by applicant]
US 20210392378A1 · Deshpande · 2021 [cited by examiner]
US 20210409690A1 · Hendry et al. · 2021 [cited by applicant]
US 20210409698A1 · Sychev · 2021 [cited by examiner]
US 20220060694A1 · Wang · 2022 [cited by applicant]
US 20220217415A1 · Hendry · 2022 [cited by examiner]
US 20220394243A1 · Deng · 2022 [cited by examiner]
US 20220394305A1 · Samuelsson · 2022 [cited by examiner]
US 20230421795A1 · Chen · 2023 [cited by examiner]
WO WO2015140401A1 · 2015 [cited by examiner]
WO 2021198491A1 · 2021 [cited by applicant]
“Gradual Tune-in Pictures for Fast Channel Change”—Jennehag et al., The 8th Annual IEEE Consumer Communications and Networking Conference; 978-1-4244-8790-5/11/$26.00 A © 2011 IEEE. (Year: 2011). [cited by examiner]
“Gradual Decoding Refresh for Versatile Video Coding”—Wang et al., Nokia Multimedia Technologies, 978-1-6654-4115-5/21/$31.00 © 2021 IEEE (Year: 2021). [cited by examiner]
Extended European Search Report received for corresponding European Patent Application No. 23174692.6, dated Oct. 30, 2023, 9 pages. [cited by applicant]
“Versatile Video Coding”, Series H: Audiovisual and Multimedia Systems Infrastructure of audiovisual services—Coding of moving video, Recommendation ITU-T H.266, Aug. 2020, 516 pages. [cited by applicant]
U.S. Appl. No. 63/296,576, “A Method, An Apparatus and A Computer Program Product for Implementing Gradual Decoding Refresh”, filed Jan. 5, 2022, pp. 1-40. [cited by applicant]
“Advanced Video Coding For Generic Audiovisual services”, Series H: Audiovisual And Multimedia Systems, Infrastructure of audiovisual services—Coding of moving Video, Recommendation ITU-T H.264, Apr. 2017, 812 pages. [cited by applicant]
“High Efficiency Video Coding”, Series H: Audiovisual And Multimedia Systems, Infrastructure of audiovisual services—Coding of moving video, Recommendation ITU-T H.265, Feb. 2018, 692 pages. [cited by applicant]
“Parameter Values for Ultra-High Definition Television Systems for Production And International Programme Exchange”, Recommendation ITU-R BT.2020, Aug. 2012, 7 pages. [cited by applicant]
“Parameter Values for the HDTV Standards for Production and International Programme Exchange”, Recommendation ITU-R BT.709-6, Jun. 2015, 19 pages. [cited by applicant]
“Versatile supplemental enhancement information messages for coded video bitstreams”, Series H: Audiovisual and Multimedia Systems Infrastructure of audiovisual services—Coding of moving video, Recommendation ITU-T H.27… [cited by applicant]
“Information Technology—Coding Of Audio-Visual Objects—Part 12: ISO Base Media File Format”, ISO/IEC 14496-12, Fifth edition, Dec. 15, 2015, 248 pages. [cited by applicant]
“Information Technology—Coding Of Audio-Visual Objects—Part 14: MP4 File Format”, ISO/IEC 14496-14, First edition, Nov. 15, 2003, 18 pages. [cited by applicant]
“Information Technology—Coding Of Audio-Visual Objects—Part 15: Advanced Video Coding (AVC) File Format”, ISO/IEC 14496-15, First edition, Apr. 15, 2004, 29 pages. [cited by applicant]
“3rd Generation Partnership Project; Technical Specification Group Services and System Aspects; Transparent end-to-end packet switched streaming service (PSS); 3GPP file format (3GP) (Release 17)”, 3GPP TS 26.244, V17.0… [cited by applicant]
Schulzrinne et al., “RTP: A Transport Protocol for Real-Time Applications”, RFC 3550, Network Working Group, Jul. 2003, pp. 1-85. [cited by applicant]
Schulzrinne et al., “RTP Profile for Audio and Video Conferences with Minimal Control”, RFC 3551, Network Working Group, Jul. 2003, pp. 1-44. [cited by applicant]
Ott et al., “Extended RTP Profile for Real-time Transport Control Protocol (RTCP) Based Feedback (RTP/AVPF)”, RFC 4585, Network Working Group, Jul. 2006, pp. 1-51. [cited by applicant]
Wang et al., “RTP Payload Format for H.264 Video”, RFC 6184, Internet Engineering Task Force (IETF), May 2011, pp. 1-101. [cited by applicant]
Wang et al., “RTP Payload Format for High Efficiency Video Coding (HEVC)”, RFC 7798, Internet Engineering Task Force (IETF), Mar. 2016, pp. 1-86. [cited by applicant]
Wenger et al., “Codec Control Messages in the RTP Audio-Visual Profile with Feedback (AVPF)”, RFC 5104, Network Working Group, Feb. 2008, pp. 1-64. [cited by applicant]
Office action received for corresponding Finnish Patent Application No. 20225598, dated Jan. 13, 2023, 9 pages. [cited by applicant]
“Test Model 12 for Versatile Video Coding (VTM 12)”, ISO/IEC JTC 1/SC 29/WG 5, N0032, Jan. 15, 2021, 102 pages. [cited by applicant]