IP Library › Granted Patent US 12,712,823
Granted Patent B2
US 12,712,823 · App. 18/756,215 · Granted Aug 18, 2026

Resource allocation for connected devices

Inventors: Sabine Randriamasy (Massy, FR); Mata Khalili (Massy, FR)
Assignee: Nokia Solutions and Networks Oy
H04L47/762H04L47/745H04L47/805
View Patent ↗
Loading inventors, assignments & file history…
Monitor This Case
Get email alerts when status or documents change.
Order Certified Copies
Most orders are placed with the USPTO same day — all within 24 business hours.
Order via The Patent Place →
Pre-filled with this patent's details
Quick Facts
Patent No.
US 12,712,823
App. No.
18/756,215
Granted
Aug 18, 2026
Kind
B2
Abstract

According to an example aspect of the present disclosure, there is provided a method comprising receiving by a control apparatus, from a client apparatus, a request for a resource allocation of one or more connected devices on one or more time ranges, receiving by the control apparatus, from an orchestrator apparatus, a work plan for a group of connected devices, wherein the work plan comprises planned positions of the group of connected devices and the group of connected devices comprises said one or more connected devices, computing by the control apparatus, based at least on the work plan, a resource allocation for each of multiple connection points on said one or more time ranges, wherein the resource allocation comprises an assignation of said one or more connected devices to the connected points and transmitting, by the control apparatus, the resource allocation to the client apparatus.

Claims (59)

1 . A control apparatus comprising:

at least one processor; and

at least one memory storing instructions that, when executed by the at least one processor, cause the apparatus at least to:

receive, from a client apparatus, a request for a resource allocation of one or more connected devices on one or more time ranges;

receive, from an orchestrator apparatus, a work plan for a group of connected devices, wherein the work plan comprises planned positions of the group of connected devices and the group of connected devices comprises said one or more connected devices;

compute, based at least on the work plan, a resource allocation for each of multiple connection points on said one or more time ranges, wherein the resource allocation comprises an assignation of said one or more connected devices to the connection points; and

transmit the resource allocation to the client apparatus.

2 . The apparatus according to claim 1 , wherein the stored instructions further cause, when executed by the at least one processor, the apparatus at least to:

receive, from the client apparatus, a requested quality of experience of a flow for said one or more connected devices for said time range; and

compute, based at least on the requested quality of experience of the flow, the resource allocation.

3 . The apparatus according to claim 1 , wherein the stored instructions further cause, when executed by the at least one processor, the apparatus at least to:

compute a connection point capability calendar on said time range; and

compute, based at least on the connection point capability calendar, the resource allocation.

4 . The apparatus according to claim 1 , wherein the stored instructions further cause, when executed by the at least one processor, the apparatus at least to:

determine a previous connection point capability calendar, wherein the previous connection point capability calendar was used before receiving the request; and

compute, based at least on the previous connection point capability calendar, the resource allocation.

5 . The apparatus according to claim 1 , wherein the stored instructions further cause, when executed by the at least one processor, the apparatus at least to:

monitor resource consumption of the connection points to detect a shortage of resources; and

adjust the resource allocation for at least one of said multiple connection points when the shortage of resources is detected at a frequency larger than a threshold; and

adjust the connection point capability calendar for at least one of said multiple connection points when the shortage of resources is detected at a frequency lower than a threshold on said connection points.

6 . The apparatus according to claim 1 , wherein the resource allocation comprises at least one network slice.

7 . A method, comprising:

receiving by a control apparatus, from a client apparatus, a request for a resource allocation of one or more connected devices on one or more time ranges;

receiving by the control apparatus, from an orchestrator apparatus, a work plan for a group of connected devices, wherein the work plan comprises planned positions of the group of connected devices and the group of connected devices comprises said one or more connected devices;

computing by the control apparatus, based at least on the work plan, a resource allocation for each of multiple connection points on said one or more time ranges, wherein the resource allocation comprises an assignation of said one or more connected devices to the connection points; and

transmitting, by the control apparatus, the resource allocation to the client apparatus.

8 . The method according to claim 7 , further comprising:

receiving by the control apparatus, from the client apparatus, a requested quality of experience attributes of a flow for said one or more connected devices for said time range; and

computing by the control apparatus, based at least on the requested quality of experience attributes of the flow, the resource allocation.

9 . The method according to claim 7 , further comprising:

computing, by the control apparatus, a connection point capability calendar on said time range; and

computing by the control apparatus, based at least on the connection point capability calendar, the resource allocation.

10 . The method according to claim 7 , further comprising:

determining, by the control apparatus, a previous connection point capability calendar, wherein the previous connection point capability calendar was used before receiving the request; and

computing by the control apparatus, based at least on the previous connection point capability calendar, the resource allocation.

11 . The method according to claim 7 , further comprising:

monitoring, by the control apparatus, resource consumption of the connection points to detect a shortage of resources; and

adjusting, by the control apparatus, the resource allocation for at least one of said multiple connection points when the shortage of resources is detected at a frequency larger than a threshold; and

adjusting the connection point capability calendar for at least one of said multiple connection points when the shortage of resources is detected at a frequency lower than a threshold on said connection points.

12 . The method according to claim 7 , wherein the resource allocation comprises at least one network slice.

13 . A non-transitory computer readable medium having stored thereon a set of computer readable instructions that, when executed by at least one processor, cause an apparatus to at least perform:

receiving, from a client apparatus, a request for a resource allocation of one or more connected devices on one or more time ranges;

receiving, from an orchestrator apparatus, a work plan for a group of connected devices, wherein the work plan comprises planned positions of the group of connected devices and the group of connected devices comprises said one or more connected devices;

computing, based at least on the work plan, a resource allocation for each of multiple connection points on said one or more time ranges, wherein the resource allocation comprises an assignation of said one or more connected devices to the connection points; and

transmitting the resource allocation to the client apparatus.

14 . The non-transitory computer readable medium according to claim 13 , wherein the stored set of computer readable instructions, when executed by the at least one processor, further cause the apparatus to at least perform:

receiving, from the client apparatus, a requested quality of experience of a flow for said one or more connected devices for said time range; and

computing, based at least on the requested quality of experience of the flow, the resource allocation.

15 . The non-transitory computer readable medium according to claim 13 , wherein the stored set of computer readable instructions, when executed by the at least one processor, further cause the apparatus to at least perform:

computing a connection point capability calendar on said time range; and

computing, based at least on the connection point capability calendar, the resource allocation.

16 . The non-transitory computer readable medium according to claim 13 , wherein the stored set of computer readable instructions, when executed by the at least one processor, further cause the apparatus to at least perform:

determining a previous connection point capability calendar, wherein the previous connection point capability calendar was used before receiving the request; and

computing, based at least on the previous connection point capability calendar, the resource allocation.

17 . The non-transitory computer readable medium according to claim 13 , wherein the stored set of computer readable instructions, when executed by the at least one processor, further cause the apparatus to at least perform:

monitoring resource consumption of the connection points to detect a shortage of resources; and

adjusting the resource allocation for at least one of said multiple connection points when the shortage of resources is detected at a frequency larger than a threshold; and

adjusting the connection point capability calendar for at least one of said multiple connection points when the shortage of resources is detected at a frequency lower than a threshold on said connection points.

18 . The non-transitory computer readable medium according to claim 13 , wherein the resource allocation comprises at least one network slice.

Assignments (2)
ASSIGNMENT OF ASSIGNOR'S INTEREST Recorded May 22, 2025
From: NOKIA NETWORKS FRANCE
To: NOKIA SOLUTIONS AND NETWORKS OY
Reel/Frame 071182/0299 →
ASSIGNMENT OF ASSIGNOR'S INTEREST Recorded May 22, 2025
From: RANDRIAMASY, SABINE; KHALILI, MATA
To: NOKIA NETWORKS FRANCE
Reel/Frame 071182/0240 →
Priority Claims (1)
FI 20235816 · Jul 12, 2023 · national
Continuity (1)
Related Publication 20250030646A1 · Jan 23, 2025
References Cited (35)
US 11310733B1 · Gupta et al. · 2022 [cited by applicant]
US 20170083368A1 · Bishop · 2017 [cited by examiner]
US 20170325120A1 · Szilagyi et al. · 2017 [cited by applicant]
US 20190158606A1 · Guim Bernat et al. · 2019 [cited by applicant]
US 20200107237A1 · Mangalvedhe · 2020 [cited by examiner]
US 20200351167A1 · Sharma et al. · 2020 [cited by applicant]
US 20210185603A1 · Bogineni et al. · 2021 [cited by applicant]
US 20210218661A1 · Wang et al. · 2021 [cited by applicant]
US 20220086846A1 · Sharma · 2022 [cited by applicant]
US 20220124560A1 · Yeh et al. · 2022 [cited by applicant]
US 20220137640A1 · Geitz et al. · 2022 [cited by applicant]
US 20220276892A1 · Randriamasy et al. · 2022 [cited by applicant]
US 20230120629A1 · Cui · 2023 [cited by examiner]
EP 3470983A1 · 2019 [cited by applicant]
WO WO2013084268A1 · 2013 [cited by examiner]
WO 2019231923A1 · 2019 [cited by applicant]
WO 2022045879A1 · 2022 [cited by applicant]
WO 2022167093A1 · 2022 [cited by applicant]
English machine translation of WO2013084268 (Year: 2013). [cited by examiner]
Extended European Search Report received for corresponding European Patent Application No. 24184715.1, dated Jan. 3, 2025, 10 pages. [cited by applicant]
Roome et al., “An Extension for Application-Layer Traffic Optimization (ALTO): Entity Property Maps”, RFC 9240, Internet Engineering Task Force (IETF), Jul. 2022, pp. 1-53. [cited by applicant]
“Interface for the communication between automated guided vehicles (AGV) and a master control”, VDA Recommendation, VDA 5050, Version 2.0.0, Jan. 2022, pp. 1-60. [cited by applicant]
Alimi et al., “Application-Layer Traffic Optimization (ALTO) Protocol”, RFC 7285, Internet Engineering Task Force (IETF), Sep. 2014, pp. 1-91. [cited by applicant]
Randriamasy et al., “Application-Layer Traffic Optimization (ALTO) Cost Calendar”, RFC 8896, Internet Engineering Task Force (IETF), Nov. 2020, pp. 1-35. [cited by applicant]
Roome et al., “Application-Layer Traffic Optimization (ALTO) Incremental Updates Using Server-Sent Events (SSE)”, RFC 8895, Internet Engineering Task Force (IETF), Nov. 2020, pp. 1-52. [cited by applicant]
Mu et al., “Intelligent Reflecting Surface Enhanced Indoor Robot Path Planning Using Radio Maps”, arXiv, Sep. 24, 2020, 7 pages. [cited by applicant]
Ghaffarkhah et al., “Communication-Aware Motion Planning in Mobile Networks”, IEEE Transactions on Automatic Control, vol. 56, No. 10, Oct. 2011, pp. 1-6. [cited by applicant]
Muralidharan et al., “Communication-Aware Robotics: Exploiting Motion for Communication”, Annual Review of Control, Robotics, and Autonomous Systems, vol. 04, 2021, pp. 1-27. [cited by applicant]
Stephan et al., “Hybrid Decentralized Control System for Communication Aware Mobile Robotic Teams”, The University of Pennsylvania , 2014, 8 pages. [cited by applicant]
Fink et al., “Robust Control of Mobility and Communications in Autonomous Robot Teams”, IEEE Access, vol. 01, May 10, 2013, pp. 290-309. [cited by applicant]
“Vehicle Finder”, Antdriven, Retrieved on Jul. 1, 2024, Webpage available at : https://www.antdriven.com/vehicle-finder?vehicles%5BsortBy%5D=vehicles. [cited by applicant]
“VDA 5050 Explained—An Overview of the Evolving Agv Communication Standard”, Bluebotics, Retrieved on Jul. 1, 2024, Webpage available at : https://bluebotics.com/vda-5050-explained-agv-communication-standard/. [cited by applicant]
Toy, “Intent-based Networking for Connectivity and Cloud Services”, Advances in Networks, vol. 09, No. 01, Mar. 10, 2021, pp. 19-22. [cited by applicant]
Fielding et al., “Hypertext Transfer Protocol (HTTP/1.1): Semantics and Content”, RFC 7231, Internet Engineering Task Force (IETF), Jun. 2014, pp. 1-101. [cited by applicant]
Office action received for corresponding Finnish Patent Application No. 20235816, dated Dec. 1, 2023, 13 pages. [cited by applicant]