IP Library › Granted Patent US 12,231,325
Granted Patent B2
US 12,231,325 · App. 17/661,383 · Granted Feb 18, 2025

Systems and methods for connecting IPV4 islands over an IPV6 core network using IPV4 provider edge routers

Inventor: Gyan S. Mishra (Boyds, MD)
Assignee: Verizon Patent and Licensing Inc.
H04L45/04H04L45/50H04L61/251H04L2101/659H04L2101/686
View Patent ↗
Loading inventors, assignments & file history…
Monitor This Case
Get email alerts when status or documents change.
Order Certified Copies
Most orders are placed with the USPTO same day — all within 24 business hours.
Order via The Patent Place →
Pre-filled with this patent's details
Quick Facts
Patent No.
US 12,231,325
App. No.
17/661,383
Granted
Feb 18, 2025
Kind
B2
Abstract

In some implementations, a first network device may encode Internet Protocol version 4 (IPv4) network layer reachability information (NLRI) using Internet Protocol version 6 (IPv6) next hop encoding to generate encoded IPv4 NLRI. The first network device may include information indicating border gateway protocol (BGP) labeled unicast (BGP-LU) in the encoded IPv4 NLRI. The first network device may advertise the encoded IPv4 NLRI. The first network device may establish a communication session with a second network device, wherein the communication session is established via an IPv6 core network. The first network device may forward, via the communication session, one or more IPv4 packets using the encoded IPv4 NLRI.

Claims (73)

1. A method, comprising:

encoding, by a first network device, Internet Protocol version 4 (IPv4) network layer reachability information (NLRI) using Internet Protocol version 6 (IPv6) next hop encoding to generate encoded IPv4 NLRI;

including, by the first network device, information indicating border gateway protocol (BGP) labeled unicast (BGP-LU) in the encoded IPv4 NLRI;

advertising, by the first network device, the encoded IPv4 NLRI;

establishing, by the first network device, a communication session with a second network device,

wherein the communication session is established via an IPv6 core network, and

wherein the communication session is established as part of a 4PE framework for transmission of the IPv4 packets; and

forwarding, by the first network device and via the communication session, one or more IPv4 packets using the encoded IPv4 NLRI,

wherein the one or more IPv4 packets are forwarded as part of the 4PE framework.

2. The method of claim 1 , wherein establishing the communication session comprises:

establishing a label switched path; and

wherein forwarding the one or more IPv4 packets comprises:

forwarding the one or more IPv4 packets via the label switched path.

3. The method of claim 1 , wherein the information indicating BGP-LU includes an address family identifier (AFI) and a subsequent address family identifier (SAFI), and

wherein a value of the AFI is different than a value of the SAFI.

4. The method of claim 1 , wherein the first network device is a first provider edge network device,

wherein the method further comprises:

receiving the one or more IPv4 packets from a first customer edge network device, and

wherein forwarding the one or more IPv4 packets comprises:

forwarding the one or more IPv4 packets toward a second customer edge network device connected to a second provider edge network device.

5. The method of claim 1 , wherein the IPv6 core network includes:

a multiprotocol label switching (MPLS) label distribution protocol (LDP) IPv6 core network,

a segment routing (SR) MPLS IPv6 core network, or

a SR over IPv6 (SRv6) core network.

6. The method of claim 1 , wherein the first network device is configured with an IPv4 address and an IPv6 address.

7. The method of claim 1 , wherein the communication session is a multiprotocol BGP (MP BGP) session, and

wherein advertising the encoded IPv4 NLRI comprises:

providing IPv4 prefixes over the MG BGP session.

8. A device, comprising:

one or more processors configured to:

encode Internet Protocol version 4 (IPv4) network layer reachability information (NLRI) using Internet Protocol version 6 (IPv6) next hop encoding to generate encoded IPv4 NLRI;

include information indicating border gateway protocol (BGP) labeled unicast (BGP-LU) in the encoded IPv4 NLRI;

advertise the encoded IPv4 NLRI; and

forward, via an Internet Protocol version 6 (IPv6) core network, one or more IPv4 packets using the encoded IPv4 NLRI,

wherein the one or more IPv4 packets are forwarded as part pf a 4PE framework.

9. The device of claim 8 , wherein the device is a first device,

wherein the one or more processors are further configured to:

establish a communication session with a second device,

wherein the communication session is established via an Internet Protocol version 6 (IPv6) core network, and

wherein the one or more IPv4 packets are forwarded toward the second device via the communication session.

10. The device of claim 9 , wherein the first device is included in a particular autonomous system, and

wherein the second device is included in the particular autonomous system.

11. The device of claim 9 , wherein the first device is included in a first autonomous system, and

wherein the second device is included in a second autonomous system.

12. The device of claim 8 , wherein the device is a first provider edge network device,

wherein the one or more processors are further configured to:

receive the one or more IPv4 packets from a first customer edge network device.

13. The device of claim 12 , wherein, to forward the one or more IPv4 packets, the one or more processors are configured to:

forward the one or more IPv4 packets toward a second customer edge network device connected to a second provider edge network device.

14. The device of claim 8 , wherein the IPv6 core network includes:

a multiprotocol label switching (MPLS) label distribution protocol (LDP) IPv6 core network,

a segment routing (SR) MPLS IPv6 core network, or

a SR over IPv6 (SRv6) core network.

15. A non-transitory computer-readable medium storing a set of instructions, the set of instructions comprising:

one or more instructions that, when executed by one or more processors of a device, cause the device to:

encode Internet Protocol version 4 (IPv4) network layer reachability information (NLRI) using Internet Protocol version 6 (IPv6) next hop encoding to generate encoded IPv4 NLRI;

include, in the encoded IPv4 NLRI, information indicating border gateway protocol (BGP) labeled unicast (BGP-LU); and

advertise the encoded IPv4 NLRI via an IPv6 BGP communication session,

wherein the IPv6 BGP communication session is established as part of a 4PE framework for connecting IPv4 islands over an IPv6 core network.

16. The non-transitory computer-readable medium of claim 15 , wherein the one or more instructions, when executed by the one or more processors, further cause the device to:

forward, via the IPv6 core network, one or more IPv4 packets using the encoded IPv4 NLRI.

17. The non-transitory computer-readable medium of claim 16 , wherein the one or more instructions, when executed by the one or more processors, further cause the device to:

establish a label switched path over the IPv6 core network,

wherein the one or more IPv4 packets are forwarded via the label switched path.

18. The non-transitory computer-readable medium of claim 15 , wherein the IPv6 core network includes:

a multiprotocol label switching (MPLS) label distribution protocol (LDP) IPv6 core network,

a segment routing (SR) MPLS IPv6 core network, or

a SR over IPv6 (SRv6) core network.

19. The non-transitory computer-readable medium of claim 15 , wherein the device is a first provider edge network device, and

wherein the one or more instructions, when executed by the one or more processors, further cause the device to:

receive one or more IPv4 packets from a first customer edge network device, and

forward the one or more IPv4 packets toward a second customer edge network device connected to a second provider edge network device.

20. The non-transitory computer-readable medium of claim 15 , wherein the device is configured with an IPv4 address and an IPv6 address.

Assignments (1)
ASSIGNMENT OF ASSIGNOR'S INTEREST Recorded Apr 29, 2022
From: MISHRA, GYAN S.
To: VERIZON PATENT AND LICENSING INC.
Reel/Frame 059711/0924 →
Continuity (1)
Related Publication 20230353480A1 · Nov 2, 2023
References Cited (47)
US 7246175B1 · Tappan · 2007 [cited by examiner]
US 9191318B1 · Van de Velde · 2015 [cited by examiner]
US 20080170578A1 · Ould-Brahim · 2008 [cited by examiner]
US 20090116483A1 · Anumala · 2009 [cited by examiner]
US 20130266013A1 · Dutta · 2013 [cited by examiner]
US 20150244628A1 · Gredler · 2015 [cited by examiner]
US 20150295888A1 · Maslak · 2015 [cited by examiner]
US 20170310589A1 · Tambakuwala · 2017 [cited by examiner]
US 20170373973A1 · Bickhart · 2017 [cited by examiner]
US 20180109450A1 · Filsfils · 2018 [cited by examiner]
US 20180351857A1 · Vairavakkalai · 2018 [cited by examiner]
US 20180351864A1 · Jeganathan · 2018 [cited by examiner]
US 20190166048A1 · Srinivasan · 2019 [cited by examiner]
US 20210336870A1 · Zhao · 2021 [cited by examiner]
US 20220345438A1 · Mishra · 2022 [cited by examiner]
US 20230275869A1 · Mishra · 2023 [cited by examiner]
US 20230353480A1 · Mishra · 2023 [cited by examiner]
US 20230370372A1 · Mishra · 2023 [cited by examiner]
“IPv4 and IPV6 Infrastructure Addresses in BGP Updates for Multicast VPN”, Request for Comments (RFC) 6515; Aggarwal; Feb. 2012 (Year: 2012). [cited by examiner]
“Evaluating an IPV4 and IPV6 Network”; Lidholm et al.; Bachelor's Thesis Kth Royal Institute of Technology; Sep. 8, 2012 (Year: 2012). [cited by examiner]
“Segment Routing Prefix Segment Identifier Extensions for BGP”; Request for Comments (RFC) 8669; Previdi et al.; Dec. 2019 (Year: 2019). [cited by examiner]
“Advertising IPV4 Network Layer Reachability Information (NLRI) with an IPV6 Next Hop”; Request for Comments (RFC) 8950; Litkowski et al.; Nov. 2020 (Year: 2020). [cited by examiner]
“Connecting IPV6 Islands over IPV4 MPLS Using IPv6 Provider Edge Routers (6PE)”; Request for Comments (RFC) 4798; Clercq et al.; Feb. 2007 (Year: 2007). [cited by examiner]
“Connecting IPV4 Islands over IPv6 Core using IPV4 Provider Edge Routers (4PE)”; Internet draft: draft-mishra-idr-v4-islands-v6-core-4pe-00; Mishra et al.; May 18, 2022 (Year: 2022). [cited by examiner]
RFC 5492; Capabilities Advertisement with BGP-4; Feb. 2009; 7 pages. [cited by applicant]
RFC 4364; BGP/MPLS IP Virtual Private Networks (VPNs); Feb. 2006; 47 pages. [cited by applicant]
RFC 4659; BGP-MPLS IP Virtual Private Network (VPN) Extension for IPV6 VPN; Sep. 2006; 18 pages. [cited by applicant]
RFC 2545; Use of BGP-4 Multiprotocol Extensions for IPV6 Inter-Domain Routing; Mar. 1999; 5 pages. [cited by applicant]
RFC 4291; IP Version 6 Addressing Architecture; Feb. 2006; 25 pages. [cited by applicant]
RFC 8277; Using BGP to Bind MPLS Labels to Address Prefixes; Oct. 2017; 23 pages. [cited by applicant]
RFC 5565; Softwire Mesh Framework; Jun. 2009; 31 pages. [cited by applicant]
RFC 8950; Advertising IPv4 Network Layer Reachability Information (NLRI) with an IPV6 Next Hop; Nov. 2020; 12 pages. [cited by applicant]
RFC 1812; Requirements for IP Version 4 Routers; Jun. 1995; 175 pages. [cited by applicant]
RFC 3032; MPLS Label Stack Encoding; Jan. 2001; 23 pages. [cited by applicant]
RFC 3270; Multi-Protocol Label Switching (MPLS) Support of Differentiated Services; May 2002; 64 pages. [cited by applicant]
RFC 4182; Removing a Restriction on the use of MPLS Explicit NULL; Sep. 2005; 7 pages. [cited by applicant]
RFC 3031; Multiprotocol Label Switching Architecture; Jan. 2001; 61 pages. [cited by applicant]
RFC 3036; LDP Specification; Jan. 2001; 132 pages. [cited by applicant]
RCF 4029; Scenarios and Analysis for Introducing IPv6 into ISP Networks; Mar. 2005; 28 pages. [cited by applicant]
RCF 4271; A Border Gateway Protocol 4 (BGP-4); Jan. 2006; 104 pages. [cited by applicant]
RFC 4443; Internet Control Message Protocol (ICMPv6) for the Internet Protocol Version 6 (IPv6) Specification; Mar. 2006; 24 pages. [cited by applicant]
RFC 4925; Softwire Problem Statement; Jul. 2007; 23 pages. [cited by applicant]
RFC 6074; Provisioning, Auto-Discovery, and Signaling in Layer 2 Virtual Private Networks (L2VPNs)Jan. 2011; 32 pages. [cited by applicant]
RFC 4684; Constrained Route Distribution for Border Gateway Protocol/MultiProtocol Label Switching (BGP/MPLS) Internet Protocol (IP) Virtual Private Networks (VPNs); Nov. 2006; 14 pages. [cited by applicant]
RFC 6513; Multicast in MPLS/BGP IP VPNs; Feb. 2012; 88 pages. [cited by applicant]
RFC 6514; BGP Encodings and Procedures for Multicast in MPLS/BGP IP VPNs; Feb. 2012; 59 pages. [cited by applicant]
Internet Assigned Numbers Authority; Capability Codes; Feb. 19, 2021; 2 pages. [cited by applicant]