IP Library › Granted Patent US 12,360,943
Granted Patent B2
US 12,360,943 · App. 18/240,078 · Granted Jul 15, 2025

Method and apparatus for media scene description

Inventors: Shuai Zhao (Palo Alto, CA); Stephan Wenger (Palo Alto, CA); Shan Liu (Palo Alto, CA)
Assignee: TENCENT AMERICA LLC
G06F16/116G06T17/00G06F8/38G06T2210/32G06T2210/61
View Patent ↗
Loading inventors, assignments & file history…
Monitor This Case
Get email alerts when status or documents change.
Order Certified Copies
Most orders are placed with the USPTO same day — all within 24 business hours.
Order via The Patent Place →
Pre-filled with this patent's details
Quick Facts
Patent No.
US 12,360,943
App. No.
18/240,078
Granted
Jul 15, 2025
Kind
B2
Abstract

Systems, methods, and devices for managing media storage and delivery, including obtaining, by a media access function (MAF), a Graphics Language Transmission Format (glTF) file corresponding to a scene; obtaining from the glTF file a uniform resource locator (URL) parameter indicating a binary data blob; determining that the binary data blob has a Concise Binary Object Representation (CBOR) format; converting the binary data blob into an object having a JavaScript Object Notation (JSON) format using a CBOR parser function implemented by the MAF; and obtaining media content corresponding to the scene based on the object.

Claims (39)

1. A method of managing media storage and delivery, the method being implemented by a Concise Binary Object Representation (CBOR) parser application programming interface (API) having at least one processor and comprising:

obtaining a Graphics Language Transmission Format (glTF) file of a scene description of a scene;

determining a CBOR format of a binary data blob indicated by the glTF file;

converting the binary data blob into an object having a JavaScript Object Notation (JSON) format; and

obtaining media content corresponding to the scene based on the object,

wherein the binary data blob is determined to have the CBOR format based on a prefix included at a beginning of the binary data blob.

2. The method of claim 1 , wherein the object having the JSON format is larger than the binary data blob having the CBOR format.

3. The method of claim 1 , wherein the binary data blob is determined to have the CBOR format based on determining both a Multipurpose Internet Mail Extension (MIME) type that is signaled in the glTF file and the prefix included at the beginning of the binary data blob.

4. The method of claim 1 , wherein a URL parameter points directly to the binary data blob.

5. The method of claim 1 , wherein the binary data blob is determined to have the CBOR format based on determining both a Multipurpose Internet Mail Extension (MIME) type that is signaled in the glTF file and the prefix included at the beginning of the binary data blob, and

wherein MIME type and the prefix both indicate “application/cbor”.

6. The method of claim 1 , wherein the MAF is included in a Moving Picture Experts Group (MPEG) scene description architecture.

7. The method of claim 1 , wherein the CBOR parser function is implemented using an application programming interface associated with the MAF.

8. A device for managing media storage and delivery, the device comprising:

at least one memory configured to store program code; and

at least one processor configured to read the program code and operate a Concise Binary Object Representation (CBOR) parser application programming interface (API) as instructed by the program code, the program code including:

first obtaining code configured to cause the at least one processor to obtain a Graphics Language Transmission Format (glTF) file of a scene description of a scene;

determining code configured to cause the at least one processor to determine a CBOR format of a binary data blob indicated by the glTF file;

converting code configured to cause the at least one processor to convert the binary data blob into an object having a JavaScript Object Notation (JSON) format; and

second obtaining code configured to cause the at least one processor to obtain media content corresponding to the scene based on the object,

wherein the binary data blob is determined to have the CBOR format based on a prefix included at a beginning of the binary data blob.

9. The device of claim 8 , wherein the object having the JSON format is larger than the binary data blob having the CBOR format.

10. The device of claim 8 , wherein the binary data blob is determined to have the CBOR format based on determining both a Multipurpose Internet Mail Extension (MIME) type that is signaled in the glTF file and the prefix included at the beginning of the binary data blob.

11. The device of claim 8 , wherein a URL parameter of the glTF file points directly to the binary data blob.

12. The device of claim 8 , wherein the binary data blob is determined to have the CBOR format based on determining both a Multipurpose Internet Mail Extension (MIME) type that is signaled in the glTF file and the prefix included at the beginning of the binary data blob, and

wherein MIME type and the prefix both indicate “application/cbor”.

13. The device of claim 8 , wherein the MAF is included in a Moving Picture Experts Group (MPEG) scene description architecture.

14. The device of claim 8 , wherein the CBOR parser function is implemented using an application programming interface associated with the MAF.

15. A non-transitory computer-readable medium storing instructions, the instructions comprising: one or more instructions that, when executed by at least one processor of a device for managing media storage and delivery, are configured to cause the at least one processor, as a Concise Binary Object Representation (CBOR) parser application programming interface (API), to:

obtain a Graphics Language Transmission Format (glTF) file of a scene description of a scene;

determine a CBOR format of a binary data blob indicated by the glTF;

convert the binary data blob into an object having a JavaScript Object Notation (JSON) format; and

obtain media content corresponding to the scene based on the object,

wherein the binary data blob is determined to have the CBOR format based on a prefix included at a beginning of the binary data blob.

16. The non-transitory computer-readable medium of claim 15 , wherein the object having the JSON format is larger than the binary data blob having the CBOR format.

17. The non-transitory computer-readable medium of claim 15 , wherein the binary data blob is determined to have the CBOR format based on determining both a Multipurpose Internet Mail Extension (MIME) type that is signaled in the glTF file and the prefix included at the beginning of the binary data blob.

18. The non-transitory computer-readable medium of claim 15 , wherein a URL parameter of the glTF file points directly to the binary data blob.

19. The non-transitory computer-readable medium of claim 15 , wherein the MAF is included in a Moving Picture Experts Group (MPEG) scene description architecture.

20. The non-transitory computer-readable medium of claim 15 , wherein the CBOR parser function is implemented using an application programming interface associated with the MAF.

Continuity (3)
Continuation 17499380 · Oct 12, 2021
Provisional Application 63137274 · Jan 14, 2021
Related Publication 20230418783A1 · Dec 28, 2023
References Cited (20)
US 10636209B1 · Thaller et al. · 2020 [cited by applicant]
US 20090066783A1 · Lee et al. · 2009 [cited by applicant]
US 20190028691A1 · Hinds et al. · 2019 [cited by applicant]
US 20190265931A1 · Kasahara · 2019 [cited by applicant]
US 20200066022A1 · Leong et al. · 2020 [cited by applicant]
US 20200120023A1 · Munson et al. · 2020 [cited by applicant]
US 20210409818A1 · Bouazizi et al. · 2021 [cited by applicant]
International Search Report dated Feb. 2, 2022 from the International Searching Authority in International Application No. PCT/US2021/054746. [cited by applicant]
Written Opinion dated Feb. 2, 2022 from the International Searching Authority in International Application No. PCT/US2021/054746. [cited by applicant]
Extended European Search Report issued May 30, 2023 in European Application No. 21918027.0. [cited by applicant]
Scully et al. “gITF Streaming from 3D Repo to X3DOM.” InProceedings of the 21st International Conference on Web3D Technology, Jul. 2016, Retrieved from the Internet <URL:https://discovery.ucl.ac.Uk/id/eprint/1517348/1/F… [cited by applicant]
Fossati, et al. “RFC 8710 Multipart Content-Format for the Constrained Application Protocol (CoAP).” Feb. 2020, <URL: http://www.ring.gr.jp/archives/doc/RFC/rfc8710.pdf> (9 pages total). [cited by applicant]
Bormann et al. (“RFC 8949 Concise Binary Object Representation (CBOR)”, Internet Engineering Task Force (IETF), Published in Nov. 2020, URL: https://www.rfc-editor.org/v3test/rfc8949.pdf (Year: 2020). [cited by applicant]
“Text of ISO/IEC CD 23090-14 Scene Description for MPEG Media”, ISO/IEC JTC 1/SC 29/WG 3, Nov. 30, 2020 (45 pages total). [cited by applicant]
I Am Axx, “CBOR”, Wikipedia, Dec. 7, 2020, (7 pages total), URL: https://en.wikipedia.org/w/index.php?title=CBOR&oldid=992856644. [cited by applicant]
International Search Report and Written Opinion of the International Searching Authority dated Jan. 25, 2022 in Application No. PCT/US21/53950. [cited by applicant]
Communication issued Nov. 29, 2024 in European Application No. 21918027.0. [cited by applicant]
“Buffers, BufferViews Accessors”, MeteorChenBo, 2019, pp. 1-3 (3pages total) https://blog.csdn.net/qq_31709249/article/details/86478460. [cited by applicant]
C. Bormann et al., “RFC 7049: Concise Binary Object Representation (CBOR)”, Internet Engineering Task Force (IETF), 2013, ISSN: 2070-1721, pp. 1-54 (54 pages total). [cited by applicant]
Office Action issued Apr. 14, 2025 in Chinese Patent Application No. 202180020882.6. [cited by applicant]