IP Library › Granted Patent US 12,395,616
Granted Patent B2
US 12,395,616 · App. 18/736,571 · Granted Aug 19, 2025

Immersive media content presentation and interactive 360° video communication

Inventors: Serhan Gül (Berlin, DE); Yago Sánchez De La Fuente (Berlin, DE); Cornelius Hellge (Berlin, DE); Thomas Schierl (Berlin, DE); Robert Skupin (Berlin, DE); Thomas Wiegand (Berlin, DE)
Assignee: Fraunhofer-Gesellschaft zur Förderung der angewandten Forschung e.V.
H04N13/194H04N13/161H04N13/172H04N13/332H04N13/366H04N21/21805H04N21/41407H04N21/6587H04N21/816
View Patent ↗
Loading inventors, assignments & file history…
Monitor This Case
Get email alerts when status or documents change.
Order Certified Copies
Most orders are placed with the USPTO same day — all within 24 business hours.
Order via The Patent Place →
Pre-filled with this patent's details
Quick Facts
Patent No.
US 12,395,616
App. No.
18/736,571
Granted
Aug 19, 2025
Kind
B2
Abstract

An apparatus for presenting immersive media content is described. The apparatus obtains from a sender video data representing immersive content for a certain viewing direction and/or for a certain viewpoint, and displays the video data representing the immersive content for the certain viewing direction and/or for the certain viewpoint.

Claims (57)

1. An apparatus for a 360° video communication with a sender, wherein

the apparatus is to

acquire from the sender video data dependent on a certain viewing direction of a 360° video, and

display the video data representing the certain viewing direction of the 360° video,

wherein, for the certain viewing direction of the 360° video, the apparatus is to trigger a switching during the session between

(i) first video data rendered by the sender and representing a 2D video at the certain viewing direction of the 360° video; and

(ii) second video data not rendered by the sender and representing at least a part of the 360° video to be transmitted by the sender using a certain projection.

2. The apparatus of claim 1 , wherein, to acquire the video data from the sender, the apparatus is to

signal to the sender the certain viewing direction of the 360° video, and

receive from the sender the video data for the certain viewing direction of the 360° video.

3. The apparatus of claim 1 , wherein the apparatus comprises

a display device to display to a user the video data for the certain viewing direction of the 360° video,

a sensor to detect the viewing direction of the user, and

a processor to signal the detected viewing direction to the sender and to process the received video data for display on the display device.

4. The apparatus of claim 1 , wherein, during the session of the 360° video communication, the apparatus is to request from the sender the first video data or the second video data dependent on an end-to-end latency between the receiver and the sender.

5. The apparatus of claim 1 , wherein

at the beginning of a session of the 360° video communication, the apparatus is to negotiate with the sender, and

when negotiating with the sender, the apparatus is to receive from the sender Supplementary Enhancement Information (SEI) messages indicating one or more of a projection type, a rotation and region-wise packing (RWP) constraints.

6. The apparatus of claim 1 , wherein the apparatus comprises a viewport predictor providing a viewport prediction, or the apparatus is to receive from the sender the viewport prediction, the viewport prediction indicating a change from the current viewing direction of the user to a new viewing direction of the user to happen after a lookahead time.

7. The apparatus of claim 1 , wherein, during the session of the 360° video communication, if a viewport size comprises a margin area, the apparatus is to receive an indication of a lens/distortion parameter used for rendering to assist the apparatus in cropping/warping a viewport.

8. An apparatus for a 360° video communication with a receiver, wherein

the apparatus is to

receive from the receiver an indication of a certain viewing direction of a 360° video at the receiver, and

transmit video data for the certain viewing direction of a 360° video to the receiver,

wherein, for the certain viewing direction of the 360° video, the apparatus is to receive a trigger for a switching during the session between

(i) first video data rendered by the apparatus and representing a 2D video at the certain viewing direction of the 360° video; and

(ii) second video data not rendered by the apparatus and representing at least a part of the 360° video to be transmitted by the apparatus using a certain projection.

9. The apparatus of claim 8 , wherein the apparatus is to,

in case the first video data is to be provided, render the video data, encode the rendered video data and transmit the encoded video data to the receiver, and

in case the second video data is to be provided, encode the video data using a certain projection, without rendering, encode one or more Supplementary Enhancement Information (SEI) messages indicating a projection type, a rotation and region-wise packing (RWP) constraints, and transmit the encoded video data and the encoded one or more messages to the receiver.

10. The apparatus of claim 8 , wherein the apparatus is to provide to the receiver the first video data or the second video data dependent on an end-to-end latency between the receiver and the sender.

11. The apparatus of claim 8 , wherein

at the beginning of a session of the 360° video communication, the apparatus is to negotiate with the receiver, and

when negotiating with the receiver, the apparatus is to send to the receiver Supplementary Enhancement Information (SEI) messages indicating one or more of a projection type, a rotation and region-wise packing (RWP) constraints.

12. The apparatus of claim 8 , wherein the apparatus comprises a viewport predictor providing a viewport prediction, or the apparatus is to receive from the receiver the viewport prediction, the viewport prediction indicating a change from the current viewing direction of the user of the receiver to a new viewing direction of the user to happen after a lookahead time.

13. The apparatus of claim 8 , wherein, during of a session of the 360° video communication, if a viewport size comprises the margin area, the apparatus is to send to the receiver an indication of a lens/distortion parameter used for rendering to assist the receiver in cropping/warping a viewport.

14. A 360° video communication system, comprising:

a sender comprising an apparatus of claim 8 , and

a receiver comprising an apparatus for a 360° video communication with a sender, wherein

the receiver is to

acquire from the sender video data dependent on a certain viewing direction of a 360° video, and

display the video data representing the certain viewing direction of the 360° video.

15. A method for a 360° video communication, the method comprising:

receiving, at a sender, an indication from a receiver of a certain viewing direction of a 360° video at the receiver, and

transmitting, by the sender, video data for the certain viewing direction of a 360° video to the receiver,

wherein, for the certain viewing direction of the 360° video, the method comprises triggering a switching during the session between

(i) first video data rendered by the sender and representing a 2D video at the certain viewing direction of the 360° video; and

(ii) second video data not rendered by the sender and representing at least a part of the 360° video to be transmitted by the sender using a certain projection.

16. The method of claim 15 , further comprising:

acquiring, by the receiver, the video data from the sender dependent on the certain viewing direction of a 360° video at the receiver, and

displaying, at the receiver the video data representing the certain viewing direction of the 360° video.

17. A non-transitory digital storage medium having a computer program stored thereon to perform, when said computer program is run by a computer, the method for a 360° video communication, the method comprising:

receiving, at a sender, an indication from a receiver of a certain viewing direction of a 360° video at the receiver, and

transmitting, by the sender, video data for the certain viewing direction of a 360° video to the receiver,

wherein, for the certain viewing direction of the 360° video, the method comprises triggering a switching during the session between

(i) first video data rendered by the sender and representing a 2D video at the certain viewing direction of the 360° video; and

(ii) second video data not rendered by the sender and representing at least a part of the 360° video to be transmitted by the sender using a certain projection.

Priority Claims (2)
EP 19175477 · May 20, 2019 · regional
EP 19194172 · Aug 28, 2019 · regional
Continuity (3)
Continuation 17527937 · Nov 16, 2021
Continuation PCTEP2020064111 · May 20, 2020
Related Publication 20240323337A1 · Sep 26, 2024
References Cited (41)
US 12041219B2 · Gül · 2024 [cited by examiner]
US 20150249813A1 · Cole et al. · 2015 [cited by applicant]
US 20160217760A1 · Chu et al. · 2016 [cited by applicant]
US 20170103576A1 · Defaria et al. · 2017 [cited by applicant]
US 20170237964A1 · Maenpaa · 2017 [cited by applicant]
US 20170302972A1 · Zhang et al. · 2017 [cited by applicant]
US 20180241988A1 · Zhou et al. · 2018 [cited by applicant]
US 20190104326A1 · Stockhammer et al. · 2019 [cited by applicant]
US 20190114830A1 · Bouazizi et al. · 2019 [cited by applicant]
US 20190158933A1 · Ouedraogo et al. · 2019 [cited by applicant]
US 20200322403A1 · Dvir et al. · 2020 [cited by applicant]
CN 106063277A · 2016 [cited by applicant]
CN 106576158A · 2017 [cited by applicant]
CN 108701369A · 2018 [cited by applicant]
CN 109155873A · 2019 [cited by applicant]
JP 2017215875A · 2017 [cited by applicant]
WO 2018069412A1 · 2018 [cited by applicant]
WO 2018093851A1 · 2018 [cited by applicant]
WO 2018106548A1 · 2018 [cited by applicant]
WO 2018123646A1 · 2018 [cited by applicant]
WO 2019083266A1 · 2019 [cited by applicant]
Schulzrinne et al., “RTP: A Transport Protocol for Real-Time Applications”, Network Working Group, RFC3550, Jul. 2003. [cited by applicant]
Wang et al., RTP Payload Format for High Efficiency Video Coding (HEVC), Internet Engineering Task Force (IETF), RFC7798, Mar. 2016. [cited by applicant]
Singer et al., “A General Mechanism for RTP Header Extensions”, Internet Engineering Task Force (IETF), RFC8285, Oct. 2017. [cited by applicant]
Ott et al., “Extended RTP Profile for Real-time Transport Control Protocol (RTCP)-Based Feedback (RTP/AVPF)”, Network Working Group, RFC4585, Jul. 2006. [cited by applicant]
Friedman et al., RTP Control Protocol Extended Reports (RTCP XR), Network Working Group, RFC3611, Nov. 2003. [cited by applicant]
Ott et al., “Guidelines for Extending the RTP Control Protocol (RTCP)”, Internet Engineering Task Force (IETF), RFC5968, Sep. 2010. [cited by applicant]
F. Andreasen, “Session Description Protocol (SDP) Capability Negotiation”, Internet Engineering Task Force (IETF), RFC5939, Sep. 2010. [cited by applicant]
Camarillo et al., “Grouping of Media Lines in the Session Description Protocol (SDP)”, Network Working Group, RFC3388, Dec. 2002. [cited by applicant]
3GPP TS 26.114 v16.0.0, “Multimedia Telephony, IMS Media Handling and Interaction”, Dec. 2018. [cited by applicant]
3GPP TS 26.223 v16.0.0 Media Handling and Interaction, Rel. 16, Mar. 2019, XP051722973. [cited by applicant]
De La Fuente et al., “Delay Impact on MPEG OMAF's Tile-Based Viewport-Dependent 360° Video Streaming”, IEEE Journal on Emerging and Selected Topics in Circuits and Systems, vol. 9, No. 1, Mar. 2019, pp. 18-28, XP0117140… [cited by applicant]
MPEG Medeia Transport (MMT), “Description of Core Experiments in MPEG Media Transport”, International Organization for Standardisation ISO/IECJTC1/SC29/WG11 Coding of Moving Pictures and Audio, N16843_MPEG, Hobart, 2017… [cited by applicant]
Feng Qian et al., “Optimizing 360 video delivery over cellular networks”, All Things Cellular, ACM, Oct. 3, 2016, pp. 1-6, XP058280180. [cited by applicant]
Huszak et al., “Advanced free viewpoint video streaming techniques”, Multimedia Tools and Applications, Kluwer Academic Publishers, vol. 76, No. 1, Nov. 11, 2015, pp. 373-396, XP036161697. [cited by applicant]
Yong He et al., “MPEG-I Architecture: VR Experience Metrics”, International Organization for Standardisation ISO/IECJTC1/SC29/WG11, 119. MPEG Meeting Jul. 2017, m41120, Jul. 2017, July 2017_XP030069463, Turin, Italy. [cited by applicant]
Yanan Bao; Tianxiao Zhang; Amit Pande; Huasen Wu; Xin Liu, Motion-Prediction-Based Multicast for 360-Degree Video Transmissions, 2017 14th Annual IEEE International Conference on Sensing, Communication, and Networking (… [cited by applicant]
Duc V. Nguyen; Huyen T. T. Tran; Anh T. Pham; Truong Cong Thang, An Optimal Tile-Based Approach for Viewport-Adaptive 360-Degree Video Streaming, IEEE Journal on Emerging and Selected Topics in Circuits and Systems, vol… [cited by applicant]
Xia Lu, The Second Office Action, Application No. 202080043973.7, Dec. 23, 2023, 11pages, China National Intellectual Property Administration. [cited by applicant]
Xin Luo et al., “360 ° realistic 3D image display and image processing from real objects” Optical Review, 2016. [cited by applicant]
Mai Xu et al., “State-of-the-Art in 360° Video/Image Processing: Perception, Assessment and Compression”, IEEE, Jan. 2020. [cited by applicant]