IP Library › Granted Patent US 12,513,074
Granted Patent B2
US 12,513,074 · App. 17/563,691 · Granted Dec 30, 2025

System and method for abstracting an IGP zone

Inventor: Huaimo Chen (Bolton, MA)
Assignee: Huawei Technologies Co., Ltd.
H04L45/04H04L41/0816H04L43/12H04L45/02
View Patent ↗
Loading inventors, assignments & file history…
Monitor This Case
Get email alerts when status or documents change.
Order Certified Copies
Most orders are placed with the USPTO same day — all within 24 business hours.
Order via The Patent Place →
Pre-filled with this patent's details
Quick Facts
Patent No.
US 12,513,074
App. No.
17/563,691
Granted
Dec 30, 2025
Kind
B2
Abstract

Various systems and methods for migrating a zone to a pseudo node are described herein including a method performed by a zone edge node. In an embodiment, the method includes receiving, by the zone edge node, an execution request to initiate migration from the zone to the pseudo node. The method also includes sending, by the zone edge node, at least one Hello packet to a zone external node adjacent to the zone edge node for requesting the zone external node to create an adjacency between the pseudo node and the zone external node on the zone external node. The method further includes creating, by the zone edge node, the adjacency between the pseudo node and the zone external node on the zone edge node.

Claims (45)

1 . A zone edge node comprising:

a memory configured to store instructions; and

a processor coupled to the memory and configured to execute the instructions to cause the zone edge node to:

receive an execution request to migrate a zone to a pseudo node;

send a Hello packet to a zone external node adjacent to the zone edge node for requesting the zone external node to create an adjacency between the pseudo node and the zone external node on the zone external node, wherein the Hello packet comprises a pseudo node identifier (ID) as a source ID of the Hello packet and an Adjacency to Abstracted Node bit (AN-bit) that is set to a value that indicates to the zone external node to create the adjacency between the pseudo node and the zone external node on the zone external node; and

create the adjacency between the pseudo node and the zone external node on the zone edge node.

2 . The zone edge node of claim 1 , wherein the Hello packet comprises an Extended Options and Flag-Type/Length/Value (EOF-TLV) comprising the AN-bit.

3 . The zone edge node of claim 1 , wherein the instructions when executed by the processor further causes the zone edge node to establish a normal adjacency between the zone edge node and the zone external node when there is not an existing adjacency between the zone edge node and the zone external node.

4 . The zone edge node of claim 1 , wherein the instructions when executed by the processor further causes the zone edge node to terminate an existing adjacency between the zone edge node and the zone external node.

5 . The zone edge node of claim 1 , wherein the instructions when executed by the processor further causes the zone edge node to:

receive a link state (LS) packet for the pseudo node, the LS packet comprising all links connecting zone external nodes to any zone edge node of the zone.

6 . The zone edge node of claim 1 , wherein the instructions when executed by the processor further causes the zone edge node to:

compute internal routes within the zone based on a topology of the zone; and

compute external routes outside the zone based on the topology of the zone and a topology outside of the zone without the pseudo node.

7 . The zone edge node of claim 1 , wherein the instructions when executed by the processor further causes the zone edge node to: advertise a zone edge node link state (LS) packet to the zone external node, wherein the zone edge node LS packet excludes all links inside the zone.

8 . The zone edge node of claim 1 , wherein the instructions when executed by the processor further causes the zone edge node to:

receive a zone external node link state (LS) packet from the zone external node; and

flood the zone external node LS packet to neighbor nodes of the zone edge node both inside and outside of the zone.

9 . A method performed by a zone leader node of a zone, the method comprising:

receiving updated link state packets originated by all zone external nodes having adjacencies with zone edge nodes of the zone;

originating a link state (LS) packet for the zone as a pseudo node;

advertising the LS packet to neighbor nodes of the zone leader node for migrating the zone to the pseudo node, wherein the LS packet comprises all links connecting the zone external nodes to any of the zone edge nodes of the zone;

receiving a command to migrate the pseudo node back to the zone;

updating the LS packet by changing every link metric for the pseudo node to a maximum metric in the LS packet to obtain an updated LS packet; and

advertising the updated LS packet to the neighbor nodes for migrating the pseudo node back to the zone.

10 . The method of claim 9 , wherein at least one of a source identifier (ID) and advertising node/router ID of the LS packet is an ID of the pseudo node for the zone.

11 . The method of claim 9 , wherein the LS packet includes stub links for routes inside the zone accessible by zone external nodes.

12 . A zone external node comprising:

a memory configured to store instructions; and

a processor coupled to the memory and configured to execute the instructions to cause the zone external node to:

receive a Hello packet requesting the zone external node create an adjacency between a pseudo node and the zone external node on the zone external node, wherein the Hello packet comprises a pseudo node identifier (ID) as a source ID of the Hello packet and an Adjacency to Abstracted Node bit (AN-bit) that is set to a value that indicates to the zone external node to create the adjacency between the pseudo node and the zone external node on the zone external node;

create the adjacency between the pseudo node and the zone external node; and

add the adjacency into a link state (LS) database of the zone external node.

13 . The zone external node of claim 12 , wherein the instructions when executed by the processor further causes the zone external node to:

generate an LS packet comprising the adjacency between the pseudo node and the zone external node; and

flood the LS packet to a zone leader node of a zone.

14 . The zone external node of claim 12 , wherein the instructions when executed by the processor further causes the zone external node to advertise a router link state advertisement (LSA).

15 . A method performed by a zone edge node for transitioning a pseudo node back to a zone, the method comprising:

receiving, from a network management system, a command to initiate migration from the pseudo node to the zone;

determining, in response to the command, whether link state (LS) packets inside the zone were advertised to zone external nodes before the zone was abstracted as the pseudo node;

sending the LS packets to the zone external nodes having connections to the zone edge node when the LS packets were advertised to the zone external nodes before the zone was abstracted as the pseudo node; and

initiating removal of an adjacency between the pseudo node and at least one of the zone external nodes by sending a Hello packet to the at least one of the zone external nodes, wherein the Hello packet comprise an Adjacency to Abstracted Node bit (AN-bit) that is set to a value that indicates a request to the at least one of the zone external nodes to remove the adjacency between the at least one of the zone external nodes and the pseudo node.

16 . The method of claim 15 , wherein initiating removal of the adjacency between the pseudo node and at least one of the zone external nodes comprises sending, by the zone edge node, a normal Hello packet to each of the zone external nodes, the normal Hello packet comprising an identifier (ID) of the zone edge node as a source ID of the normal Hello packet.

17 . The method of claim 15 , wherein initiating removal of the adjacency between the pseudo node and at least one of the zone external nodes comprises terminating sending of Hello packets for the adjacency to the at least one of the zone external nodes.

18 . The method of claim 15 , wherein the Hello packet comprises an Extended Options and Flag-Type/Length/Value (EOF-TLV) comprising the AN-bit.

Assignments (1)
ASSIGNMENT OF ASSIGNOR'S INTEREST Recorded Nov 18, 2025
From: FUTUREWEI TECHNOLOGIES, INC.
To: HUAWEI TECHNOLOGIES CO., LTD.
Reel/Frame 073597/0189 →
Continuity (3)
Continuation PCTUS2020039756 · Jun 26, 2020
Provisional Application 62868684 · Jun 28, 2019
Related Publication 20220123994A1 · Apr 21, 2022
References Cited (32)
US 7296087B1 · Ashwood Smith · 2007 [cited by examiner]
US 7496650B1 · Previdi · 2009 [cited by examiner]
US 20040136347A1 · Fuke · 2004 [cited by examiner]
US 20060140123A1 · Conner · 2006 [cited by examiner]
US 20060209719A1 · Previdi · 2006 [cited by examiner]
US 20100020719A1 · Chu · 2010 [cited by examiner]
US 20130089005A1 · Li · 2013 [cited by examiner]
US 20160057049A1 · Jacobson · 2016 [cited by examiner]
US 20160248659A1 · Chen et al. · 2016 [cited by applicant]
US 20160373336A1 · Chen · 2016 [cited by examiner]
US 20170324644A1 · Chen · 2017 [cited by examiner]
CN 106973018A · 2017 [cited by applicant]
WO 2013052893A1 · 2013 [cited by applicant]
WO WO2017020619A1 · 2017 [cited by examiner]
Bradner, “Key Words for Use in RFCs to Indicate Requirement Levels,” BCP 14, RFC 2119, Mar. 1997, 3 pages. [cited by applicant]
Callon, “Use of OSI-IS for Routing in TCP/IP and Dual Environments,” RFC 1195, Dec. 1990, 68 pages. [cited by applicant]
Chen, et al., “OSPF Topology-Transparent Zone,” RFC 8099, Feb. 2017, 27 pages. [cited by applicant]
Clos, “A Study of Non-Blocking Switching Networks,” The Bell System Technical Journal vol. 32(2), DOI 10.1002/j.1538-7305.1953.tb01433.x, Mar. 1953. [cited by applicant]
Filsfils, Ed., et al., “Segment Routing architecture,” draft-ietf-spring-segment-routing-15, Jan. 25, 2018, 31 pages. [cited by applicant]
International Organization for Standardization, “Intermediate System to Intermediate System Intra-domain Routing Information Exchange Protocol for Use in Conjunction with the Protocol for Providing the Connectionless-mo… [cited by applicant]
Kompella, Ed., et al., “IS-IS Extensions in Support of Generalized Multi-Protocol Label Switching (GMPLS),” RFC 5307, Oct. 2008, 12 pages. [cited by applicant]
Li, “Level 1 Area Abstraction for IS-IS,” draft-li-area-abstraction-00, Jun. 28, 2018, 6 pages. [cited by applicant]
Li, Ed., et al., “Dynamic Flooding on Dense Graphs,” draft-ietf-lsr-dynamic-flooding-03, Jun. 4, 2019, 47 pages. [cited by applicant]
Li, et al., “IS-IS Extensions for Traffic Engineering,” RFC 5305, Oct. 2008, 17 pages. [cited by applicant]
Moy, “OSPF Version 2,” RFC 2328, Apr. 1998, 244 pages. [cited by applicant]
Shand, et al., “Reclassification of RFC 1142 to Historic,” RFC 7142, Feb. 2014, 3 pages. [cited by applicant]
Vasseur, et al., “Definition of an IS-IS Link Attribute Sub-TLV,” RFC 5029, Sep. 2007, 6 pages. [cited by applicant]
Zinin, et al., “OSPF Link-Local Signaling,” RFC 5613, Aug. 2009, 12 pages. [cited by applicant]
Chen, et al., “IS-IS Topology-Transparent Zone,” draft-chen-isis-ttz-05, Mar. 5, 2018, 17 pages. [cited by applicant]
H. Chen et al: “IS-IS Topology-Transparent Zone draft-chen-isis-ttz-05.txt.” Mar. 5, 2018. total 17 pages. [cited by applicant]
T. Li et al: “Level 1 Area Abstraction for IS-IS draft-li-lsr-isis-area-abstraction-00.” Dec. 7, 2018. total 7 pages. [cited by applicant]
H. Chen et al: “OSPF Topology-Transparent Zone.” rfc-editor.org/rfc/rfc8099.txt. Feb. 2017. total 22 pages. [cited by applicant]