IP Library › Granted Patent US 12,519,733
Granted Patent B2
US 12,519,733 · App. 17/561,886 · Granted Jan 6, 2026

Multi-access management service enhancements for quality of service and time sensitive applications

Inventors: Jing Zhu (Portland, OR); Menglei Zhang (Portland, OR); Wey-Yi Guy (Beaverton, OR); Valerie Parker (Portland, OR)
Assignee: Intel Corporation
H04L47/2483H04L47/2441H04L47/2475H04L47/283H04L47/34
View Patent ↗
Loading inventors, assignments & file history…
Monitor This Case
Get email alerts when status or documents change.
Order Certified Copies
Most orders are placed with the USPTO same day — all within 24 business hours.
Order via The Patent Place →
Pre-filled with this patent's details
Quick Facts
Patent No.
US 12,519,733
App. No.
17/561,886
Filed
Dec 24, 2021
Granted
Jan 6, 2026
Kind
B2
Art Unit
2412
USPC
370/230
Abstract

The present disclosure is related to multi-access traffic shaping mechanisms and data rate and/or bandwidth estimation techniques. The traffic shaping and rate/bandwidth techniques may be used in Multi-Access Management Services (MAMS) framework, which is a programmable framework that provides mechanisms for the flexible selection of network paths in a multi-access (MX) communication environment, based on an application's needs. Other embodiments may be described and/or claimed.

Claims (52)

1 . A multi-access (MX) compute node to operate in an MX computing environment, the MX compute node comprising:

memory circuitry; and

processor circuitry connected to the memory circuitry, the processor circuitry to execute instructions of an MX traffic shaper, which, when executed are to cause the processor circuitry to:

classify incoming packets into a traffic class (TC) of a plurality of TCs;

select, for each packet of the incoming packets, one or more access networks of a plurality of access networks to deliver the incoming packets to a destination device according to the TC of each packet;

store each packet in a corresponding queue of a plurality of queues according to the TC of each packet such that each packet having a same TC is stored in a same queue of the plurality of queues, wherein the plurality of queues includes a set of queues for each access network of the plurality of access networks, and each set of queues includes a queue corresponding to each TC in the plurality of TCs;

schedule packets for delivery to the selected one or more access networks based on a TC of each queue of the plurality of queues and based on the access network associated with each queue; and

cause delivery of the queued packets to the one or more access networks based on the scheduling.

2 . The MX compute node of claim 1 , wherein each TC of the plurality of TCs corresponds to a quality of service (QOS) class, priority level, or a set of application requirements.

3 . The MX compute node of claim 1 , wherein, to select the one or more access networks, execution of the instructions is to cause the processor circuitry to:

select one access network of the plurality of access networks for each packet classified as belonging to a first TC of the plurality of TCs; and

select multiple access networks of the plurality of access networks for each packet classified as belonging to a second TC of the plurality of TCs.

4 . The MX compute node of claim 1 , wherein execution of the instructions is to cause the processor circuitry to:

select one access network of the plurality of access networks for a set of the incoming packets classified as belonging to a first TC of the plurality of TCs; and

select multiple access networks of the plurality of access networks for a set of the incoming packets classified as belonging to a second TC of the plurality of TCs such that different access networks of the plurality of access networks are selected for different subsets of the set of incoming packets classified as belonging to the second TC.

5 . The MX compute node of claim 1 , wherein the plurality of queues includes a set of queues for each access network of the plurality of access networks, and each set of queues includes a queue corresponding to a TC in the plurality of TCs.

6 . The MX compute node of claim 1 , wherein execution of the instructions is to cause the processor circuitry to:

determine a number of TCs in the plurality of TCs based on a received traffic shaping configuration, wherein the traffic shaping configuration includes, for each TC in the plurality of TCs, a TC identifier (ID), a set of TC parameters, and a set of TC-specific tunneling parameters.

7 . The MX compute node of claim 6 , wherein the set of TC parameters includes a source network address, a destination network addresses, a protocol type, source port number, and a destination port number.

8 . The MX compute node of claim 6 , wherein:

the traffic shaping configuration includes, for each TC in the plurality of TCs, a number of transmission schedules for each TC, wherein each transmission schedule in the number of transmission schedules indicates a period during which transmission are to take place, and for each transmission schedule, the traffic shaping configuration includes a start time, a transmission duration, and a transmission period; or

the traffic shaping configuration includes, for each TC in the plurality of TCs, a number of no-transmission schedules for each TC, wherein each no-transmission schedule in the number of no-transmission schedules indicates a period during which no transmissions are to take place, and for each no-transmission schedule, the traffic shaping configuration includes a start time, a no-transmission duration, and a no-transmission period.

9 . The MX compute node of claim 6 , wherein the traffic shaping configuration includes, for each access network in the plurality of access networks, a transmission rate for scheduling transmissions and a queueing mode for scheduling transmissions.

10 . The MX compute node of claim 9 , wherein the traffic shaping configuration includes, for each TC of the plurality of TCs, a TC ID, and one of:

a priority assigned to a queue of the plurality of queues corresponding to the TC ID when the queueing mode is a strict-priority mode; and

a weighted round robin (WRR) weight assigned to a queue of the plurality of queues corresponding to the TC ID when the queueing mode is a WRR mode.

11 . The MX compute node of claim 1 , wherein the MX traffic shaper is part of a convergence layer in a Multi-Access Management Services (MAMS) control plane protocol stack.

12 . The MX compute node of claim 1 , wherein execution of the instructions is to cause the MX compute node to:

classify incoming packets into a traffic class (TC) of a plurality of TCs;

select, for each packet of the incoming packets, one or more access networks of a plurality of access networks to deliver the incoming packets to a destination device according to the TC of each packet;

store each packet in a corresponding queue of a plurality of queues according to the TC of each packet such that each packet having a same TC is stored in a same queue of the plurality of queues;

schedule packets for delivery to the selected one or more access networks based on a TC of each queue of the plurality of queues; and

cause delivery of the queued packets to the one or more access networks based on the scheduling.

13 . The MX compute node of claim 1 , wherein the MX compute node is a client device.

14 . One or more non-transitory computer readable media (NTCRM) comprising instructions, wherein execution of the instructions by one or more processors of a multi-access (MX) compute node is to cause the MX compute node to:

determine to operate an MX traffic shaping function when a peer MX compute node indicates support for an MX traffic shaping capability in a capability message; and

when the peer MX compute node indicates support for the MX traffic shaping capability,

classify incoming packets into a traffic class (TC) of a plurality of TCs;

selecting, for each packet of the incoming packets, one or more access networks of a plurality of access networks to deliver the incoming packets to a destination device according to the TC of each packet;

storing each packet in a corresponding queue of a plurality of queues according to the TC of each packet such that each packet having a same TC is stored in a same queue of the plurality of queues, wherein the plurality of queues includes a set of queues for each access network of the plurality of access networks, and each set of queues includes a queue corresponding to each TC in the plurality of TCs;

scheduling packets for delivery to the selected one or more access networks based on a TC of each queue of the plurality of queues and based on the access network associated with each queue; and

cause delivery of the queued packets to the one or more access networks based on the scheduling.

15 . The one or more NTCRM of claim 14 , wherein execution of the instructions is to cause the MX compute node to:

determine whether the peer MX compute node supports a TC-specific tunneling capability based on the information included in the capability message, wherein, when the peer MX compute node supports the TC-specific tunneling capability, the MX traffic shaping function includes, for each TC in the plurality of TCs, a set of TC-specific tunneling parameters, and the set of TC-specific tunneling parameters includes a transport port number and a QoS class or treatment;

establish a dedicated transport tunnel with the peer MX compute node for communicating packets having a TC indicated by the set of TC-specific tunneling parameters; and

map a quality of service (QOS) treatment to a transport flow to be communicated through the dedicated transport tunnel.

16 . The one or more NTCRM of claim 15 , wherein execution of the instructions is to cause the MX compute node to:

determine whether the peer MX compute node supports a time synchronization (sync) capability based on the information included in a capability message;

receive a time sync configuration message when the peer MX compute node supports the time sync capability;

perform one or more time sync operations based on information included in the time sync configuration message; and

send a time sync configuration response message to the peer MX node including an indicator indicating success or failure of the one or more time sync operations.

17 . The one or more NTCRM of claim 16 , wherein the time sync configuration includes a time sync transport type, a time sync protocol, a time sync network address, and a time sync port number.

Assignments (1)
ASSIGNMENT OF ASSIGNOR'S INTEREST Recorded Dec 24, 2021
From: ZHU, JING; ZHANG, MENGLEI; GUY, WEY-YI; PARKER, VALERIE
To: INTEL CORPORATION
Reel/Frame 058476/0525 →
Continuity (1)
Related Publication 20220124043A1 · Apr 21, 2022
References Cited (165)
US 6957212B2 · Peng · 2005 [cited by applicant]
US 8355399B1 · Wilson · 2013 [cited by examiner]
US 8949501B1 · Akhter et al. · 2015 [cited by applicant]
US 9398121B1 · Brandwine · 2016 [cited by applicant]
US 12096276B2 · Han · 2024 [cited by examiner]
US 20030091054A1 · Futenma · 2003 [cited by applicant]
US 20060168336A1 · Koyanagi · 2006 [cited by applicant]
US 20070177626A1 · Kotelba · 2007 [cited by examiner]
US 20080062934A1 · Zhao · 2008 [cited by examiner]
US 20100202323A1 · Nishida · 2010 [cited by applicant]
US 20110188498A1 · Inagaki · 2011 [cited by examiner]
US 20130077486A1 · Keith · 2013 [cited by examiner]
US 20130246672A1 · Saputra · 2013 [cited by applicant]
US 20140307593A1 · Zhao et al. · 2014 [cited by applicant]
US 20150029879A1 · Chou et al. · 2015 [cited by applicant]
US 20150078359A1 · Scahill et al. · 2015 [cited by applicant]
US 20150215835A1 · Sirotkin · 2015 [cited by applicant]
US 20150319741A1 · Li · 2015 [cited by examiner]
US 20160112896A1 · Karampatsis · 2016 [cited by applicant]
US 20160270145A1 · Srinivasa Gopalan et al. · 2016 [cited by applicant]
US 20160381491A1 · Watfa et al. · 2016 [cited by applicant]
US 20170019830A1 · Lindoff et al. · 2017 [cited by applicant]
US 20170093541A1 · Pan et al. · 2017 [cited by applicant]
US 20170339217A1 · Morrill · 2017 [cited by examiner]
US 20180018385A1 · Katayama et al. · 2018 [cited by applicant]
US 20180027508A1 · Tanaka · 2018 [cited by applicant]
US 20180077022A1 · Van Oost et al. · 2018 [cited by applicant]
US 20180092085A1 · Shaheen et al. · 2018 [cited by applicant]
US 20180270742A1 · Bergstrom et al. · 2018 [cited by applicant]
US 20190036841A1 · Nolan · 2019 [cited by applicant]
US 20190306749A1 · Bergstrom et al. · 2019 [cited by applicant]
US 20190306752A1 · Lai · 2019 [cited by applicant]
US 20190394833A1 · Talebi Fard et al. · 2019 [cited by applicant]
US 20200045612A1 · Stauffer et al. · 2020 [cited by applicant]
US 20200053018A1 · White et al. · 2020 [cited by applicant]
US 20200178196A1 · Wang et al. · 2020 [cited by applicant]
US 20200229038A1 · Zhu · 2020 [cited by examiner]
US 20200366608A1 · Pan · 2020 [cited by examiner]
US 20210051104A1 · He · 2021 [cited by applicant]
US 20210058936A1 · Gordaychik · 2021 [cited by applicant]
US 20210100047A1 · Chiba et al. · 2021 [cited by applicant]
US 20210144590A1 · Li · 2021 [cited by applicant]
US 20210211914A1 · De La Oliva et al. · 2021 [cited by applicant]
US 20210306900A1 · Mehta · 2021 [cited by applicant]
US 20210385865A1 · Mueck · 2021 [cited by applicant]
US 20210400537A1 · Zhang et al. · 2021 [cited by applicant]
US 20210409335A1 · Zhu et al. · 2021 [cited by applicant]
US 20220191733A1 · Ali et al. · 2022 [cited by applicant]
US 20230056442A1 · Ly et al. · 2023 [cited by applicant]
US 20230189368A1 · Zhou · 2023 [cited by applicant]
US 20230276483A1 · Xu et al. · 2023 [cited by applicant]
EP 3414932A1 · 2018 [cited by applicant]
WO WO2015152787A1 · 2015 [cited by applicant]
WO WO2017139699A1 · 2017 [cited by applicant]
WO WO2017189176A2 · 2017 [cited by applicant]
WO WO2019076440A1 · 2019 [cited by applicant]
WO WO2019192528A1 · 2019 [cited by applicant]
WO WO2020232404A1 · 2020 [cited by applicant]
WO WO2021257974A1 · 2021 [cited by applicant]
WO WO2022005917A1 · 2022 [cited by applicant]
WO WO2022005918A1 · 2022 [cited by applicant]
International Preliminary Report on Patentability mailed Dec. 29, 2022 for International Patent Application PCT/US2021/038063, 10 pages. [cited by applicant]
Nádas et al., “Per Packet Value: A Practical Concept for Network Resource Sharing”, 2016 IEEE Global Communications Conference (GLOBECOM), pp. 1-7 (Dec. 4, 2016). [cited by applicant]
Laki et al., “Take your own share of the PIE”, Proceedings of the Applied Networking Research Workshop, pp. 27-32 (Jul. 15, 2017). [cited by applicant]
Nádas et al., “Towards a congestion control-independent core-stateless AQM”, Proceedings of the Applied Networking Research Workshop, pp. 84-90 (Jul. 16, 2018). [cited by applicant]
Laki et al., “Scalable Per Subscriber QoS with Core-Stateless Scheduling”, ACM SIGCOMM Industrial Demos, 2 pages (2018). [cited by applicant]
Nádas et al., “Stateless resource sharing in networks with multi-layer virtualization”, 2019 IEEE International Conference on Communications (ICC), pp. 1-7 (May 20, 2019). [cited by applicant]
Nádas et al., “Towards core-stateless fairness on multiple timescales”, Proceedings of the Applied Networking Research Workshop, pp. 30-36 (Jul. 22, 2019). [cited by applicant]
Fejes et al., “Decoupling delay and resource sharing targets with efficient core-stateless AQM”, Proceedings of the ACM SIGCOMM 2019 Conference Posters and Demos, pp. 128-130 (Aug. 19, 2019). [cited by applicant]
Fejes et al., “Who will Save the Internet from the Congestion Control Revolution?”, Proceedings of the 2019 Workshop on Buffer Sizing, Stanford University, 6 pages (2019), http://ppv.elte.hu/buffer-sizing/. [cited by applicant]
Fejes et al., “On the Incompatibility of Scalable Congestion Controls over the Internet”, 2020 IFIP Networking Conference (Networking), IEEE, pp. 749-754 (Jun. 22, 2020), http://ppv.elte.hu/scalable-cc-comp/. [cited by applicant]
Nádas et al., A congestion control independent L4S scheduler. InProceedings of the Applied Networking Research Workshop, pp. 45-51 (Jul. 27, 2020). [cited by applicant]
Laki et al., “Core-Stateless Forwarding With QoS Revisited: Decoupling Delay and Bandwidth Requirements”, IEEE/ACM Transactions on Networking 29, No. 2, pp. 503-516 (Dec. 9, 2020). [cited by applicant]
Fejes et al., “A Core-Stateless L4S Scheduler for P4-enabled hardware switches with emulated HQoS”, IEEE INFOCOM 2021 Demo (Virtual), 2 pages (2021), http://ppv.elte.hu/ic21/. [cited by applicant]
Bemten et al., “Network Calculus: A Comprehensive Guide”, Technical Report No. 201603, 57 pages (Oct. 8, 2016). [cited by applicant]
Charny et al., “Delay Bounds in a Network with Aggregate Scheduling”, International Workshop on Quality of Future Internet Services 2000 (QoFIS'2000), Springer Berlin, Heidelberg, pp. 1-13 (Sep. 25, 2000). [cited by applicant]
Zhu et al., “Generic Multi-Access (GMA) Encapsulation Protocol”, draft-zhu-intarea-gma-07, 13 pages (May 14, 2020). [cited by applicant]
Feng et al., “The Blue active queue management algorithms”, 19 pages, (Sep. 2002), http://www.researchgate.net/publication/3334841. [cited by applicant]
Mustafa Maad Hamdi et al., “A review on Queue Management Algorithms in Large Networks”, IOP Conference Series: Materials Science and Engineering, vol. 1076, No. 1, p. 012034, 13 pages (Feb. 1, 2021), https://iopscience.… [cited by applicant]
Nichols et al., “Definition of the Differentiated Services Field (DS Field) in the IPV4 and IPV6 Headers”, IETF RFC 2474, 20 pages (Dec. 1998). [cited by applicant]
Ramakrishnan et al., “The Addition of Explicit Congestion Notification (ECN) to IP”, IETF RFC 3168, 63 pages (Sep. 2001). [cited by applicant]
Amante et al., “IPv6 Flow Label Specification”, IETF RFC 6437, 15 pages (Nov. 2011). [cited by applicant]
D. Black, “Relaxing Restrictions on Explicit Congestion Notification (ECN) Experimentation”, IETF RFC 8311, 20 pages (Jan. 2018). [cited by applicant]
G. Fairhurst, “Update to IANA Registration Procedures for Pool 3 Values in the Differentiated Services Field Codepoints (DSCP) Registry”, IETF RFC 8436, 7 pages (Aug. 2018). [cited by applicant]
Zhu et al., “Improving QoE for Skype Video Call in Mobile Broadband Network”, 2012 IEEE Global Communications Conference (GLOBECOM), pp. 1938-1943 (Dec. 3, 2012). [cited by applicant]
Kanugovi et al., “Control Plane Protocols and Procedures for Multiple Access Management Services”, IETF, draft-zhu-intarea-mams-control-protocol-02 (Jul. 3, 2017), 31 pages. [cited by applicant]
Li et al., “Multipath Transmission for Internet: A Survey”, 39 pages, IEEE Communications Surveys & Tutorials, vol. 18, No. 4, Fourth Quarter 2016, pp. 2887-2925 (Jun. 29, 2016). [cited by applicant]
“TCP Keep-Alives” in Braden, “Requirements for Internet Hosts—Communication Layers”, IETF RFC 1122, section 4.2.3.6, pp. 101-102 (Oct. 1, 1989), 2 pages. [cited by applicant]
International Search Report and Written Opinion mailed Oct. 8, 2021 for International Patent Application No. PCT/US2021/039253, 12 pages. [cited by applicant]
“3rd Generation Partnership Project; Technical Specification Group Services and System Aspects; Study on access traffic steering, switch and splitting support in the 5G system architecture (Release 16)”, 3GPP TR 23.793 … [cited by applicant]
“3rd Generation Partnership Project; Technical Specification Group Services and System Aspects; Study on Access Traffic Steering, Switch and Splitting support in the 5G system architecture Phase 2 (Release 17)”, 3GPP TR… [cited by applicant]
International Preliminary Report on Patentability mailed Jan. 12, 2023 for International Patent Application No. PCT/US2021/039253, 7 pages. [cited by applicant]
International Search Report and Written Opinion mailed Nov. 19, 2021 for International Patent Application No. PCT/US2021/039252, 13 pages. [cited by applicant]
International Preliminary Report on Patentability mailed Jan. 12, 2023 for International Patent Application No. PCT/US2021/039252, 8 pages. [cited by applicant]
U.S. Appl. No. 63/025,086 “Dynamic Traffic Management in Next Generation Multi-Access Management Service Frameworks”, filed May 14, 2020, 78 pages. [cited by applicant]
U.S. Appl. No. 17/922,947 “RAN-Aware Traffic Distribution Rules and RAN Measurements for Enhanced Access Traffic Steering Switching and Splitting ”, filed Nov. 2, 2022, 92 pages. [cited by applicant]
U.S. Appl. No. 17/925,430 “Wireless Local Area Network Enhancements for Access Traffic Steering Switching Splitting”, filed Nov. 15, 2022, 64 pages. [cited by applicant]
“3rd Generation Partnership Project; Technical Specification Group Services and System Aspects; System architecture for the 5G System (5GS); Stage 2 (Release 15)”, 3GPP TS 23.501 V15.9.0 (Mar. 27, 2020), 248 pages. [cited by applicant]
A. Ford et al., “RFC 8684 TCP Extensions for Multipath Operation with Multiple Addresses”: http://tools.ietf.org/html/draft-ietf-mptcp-multiaddressed-09, 6 pages (Mar. 2020). [cited by applicant]
“3rd Generation Partnership Project; Technical Specification Group Services and System Aspects; Management and orchestration; 5G performance measurements (Release 16)”, 3GPP TS 28.552 V16.5.0 (Mar. 27, 2020), 173 pages. [cited by applicant]
“3rd Generation Partnership Project; Technical Specification Group Radio Access Network; Evolved Universal Terrestrial Radio Access (E-UTRA); Layer 2—Measurements (Release 15)”, 3GPP TS 36.314 V15.2.0 (Jan. 11, 2019), 2… [cited by applicant]
“IEEE Standard for Information technology—Telecommunications and information exchange between systems Local and metropolitan area networks—Specific requirements—Part 11: Wireless LAN Medium Access Control (MAC) and Phys… [cited by applicant]
Wi-Fi Alliance, “Wi-Fi Agile Multiband Technical Specification”, Version 1.5, 32 pages (2020). [cited by applicant]
Wi-Fi Alliance, “Optimized Connectivity Specification”, Version 1.1.6, 26 pages (2020). [cited by applicant]
Nikc Mckeown et al., “Tiny Tera: A Packet Switch Core”, IEEE Micro, IEEE Service Center, Los Alamitos, CA, US deel 17, nr.1, (Jan. 1, 1997), 8 pages. [cited by applicant]
S. Kanugovi et al., “Multi-Access Management Services (MAMS)”, rtc8743.txt, Multi-Access Management Services (MAMS); rfc8743.txt, Internet Engineering Task Force, IETF; Standard, Internei Society (ISOC) 4, Rue Des Falai… [cited by applicant]
J. Zhu et al., “Generic Multi-Access (GMA) Encapsulation Protocol draft-zhu-intarea-gma-07”, Intarea/Network Working Group Draft, 13 pages (May 14, 2020), https://datatracker.ietf.org/doc/html/draft-zhu-intarea-gma-07. [cited by applicant]
S. Kanugovi et al., “Multi-Access Management Services (MAMS)”, IETF RFC 8743, 143 pages (Mar. 2020), https://www.rfc-editor.org/rfc/rfc8743.html. [cited by applicant]
International Search Report and Written Opinion mailed Oct. 6, 2021 for Int'l App. No. PCT/US2021/038063, 14 bages. [cited by applicant]
“3GPP; TSG SA; Study on enhanced support of Industrial Internet of Things (IIoT) in 5G System (Release 17)”, 3GPP TR 23.700-20 V0.3.0 (Jan. 28, 2020). [cited by applicant]
Han-Chuan Hsieh et al., “5G Virtualized Multi-access Edge Computing Platform for IoT Applications”, Journal of Network and Computer Applications, vol. 115, pp. 94-102 (May 10, 2018). [cited by applicant]
International Preliminary Report on Patentability mailed Oct. 13, 2022 for International Patent Application PCT/US2020/066969, 8 pages. [cited by applicant]
International Search Report and Written Opinion mailed Apr. 15, 2021 for International Patent Application PCT/US2020/066969, 13 pages. [cited by applicant]
International Search Report and Written Opinion mailed Aug. 31, 2020 for International Patent Application No. PCT/US2020/033261, 14 pages. [cited by applicant]
International Preliminary Report on Patentability mailed Nov. 25, 2021 for International Patent Application No. PCT/US2020/033261, 10 pages. [cited by applicant]
“3rd Generation Partnership Project; Technical Specification Group Services and System Aspects; Study on access traffic steering, switch and splitting support in the 5G system architecture (Release 16)”, 3GPP TR 23.793 … [cited by applicant]
S. Kanugovi et al., “Multiple Access Management Services”, draft-kanugovi-intarea-mams-framework-03, Internet Engineering Task Force (IETF), 156 pages (Feb. 28, 2019), https://tools.ietf.org/search/draft-kanugovi-intare… [cited by applicant]
S. Kanugovi et al., Multiple Access Management Services, draft-kanugovi-intarea-mams-framework-04, Internet Engineering Task Force (IETF), 122 pages (May 31, 2019), https://datatracker.ietf.org/doc/html/draft-kanugovi-i… [cited by applicant]
J. Zhu et al., “User-Plane Protocols for Multiple Access Management Service”, draft-zhu-intarea-mams-user-protocol-07, Internet Engineering Task Force (IETF), 14 pages (Apr. 3, 2019), https://datatracker.ietf.org/doc/ht… [cited by applicant]
“3rd Generation Partnership Project; Technical Specification Group Services and System Aspects; System Architecture for the 5G System; Stage 2 (Release 16)”, 3GPP TS 23.501 v16.1.0, 368 pages (Jun. 11, 2019). [cited by applicant]
“3rd Generation Partnership Project; Technical Specification Group Core Network and Terminals; 5G System; Access and Mobility Management Services; Stage 3 (Release 16)”, 3GPP TS 29.518 V16.0.0, 199 pages (Jun. 13, 2019). [cited by applicant]
“Multi-access Edge Computing (MEC); Framework and Reference Architecture”, ETSI GS MEC 003 V2.1.1, 21 pages (Jan. 2019). [cited by applicant]
“Multi-access Edge Computing (MEC); Phase 2: Use Cases and Requirements”, ETSI GS MEC 002 V2.1.1, 66 pages (Oct. 2018). [cited by applicant]
“Mobile Edge Computing(MEC); Bandwidth Management API”, ETSI GS MEC 015 V1.1.1, 20 pages (Oct. 2017). [cited by applicant]
“3rd Generation Partnership Project; Technical Specification Group Core Network and Terminals; 5G System; Network Exposure Function Northbound APIs; Stage 3 (Release 16)”, 3GPP TS 29.522 V16.0.0, 43 pages (Jun. 18, 2019… [cited by applicant]
“Multi-access Edge Computing (MEC); General principles for MEC Service APIs Disclaimer”, ETSI GS MEC 009 V2.1.1, 64 pages (Jan. 2019). [cited by applicant]
“3rd Generation Partnership Project; Technical Specification Group Services and System Aspects; System Architecture for the 5G System; Stage 2 (Release 16)” 3GPP TS 23.501 v16.0.2, 317 pages (Apr. 1, 2019). [cited by applicant]
“3rd Generation Partnership Project; Technical Specification Group Core Network and Terminals; 5G System; Access and Mobility Management Services; Stage 3 (Release 15)”, 3GPP TS 29.518 V15.3.0, 195 pages (Mar. 24, 2019). [cited by applicant]
“Mobile Edge Computing (MEC); Radio Network Information API”, ETSI GS MEC 012 V1.1.1, 57 pages (Jul. 2017). [cited by applicant]
Extended European Search Report issued Jun. 14, 2024 for EP Application No. 21825017.3, 4 pages. [cited by applicant]
Deutsche Bahn AG, “Exemplary Mapping of 3GPP Building Blocks to FRMCS Logical Architecture Draft,” ETSI Draft RT(19)075028r3, ETSI, Dec. 12, 2019, 13 pages. [cited by applicant]
Office Action mailed Jun. 21, 2024 for U.S. Appl. No. 17/437,711, 96 pages. [cited by applicant]
Notice of Allowance mailed Aug. 20, 2024 for U.S. Appl. No. 17/469,331, 21 pages. [cited by applicant]
Notice of Allowance mailed Aug. 2, 2024 for U.S. Appl. No. 17/923,170, 71 pages. [cited by applicant]
Office Action mailed Sep. 18, 2024 for U.S. Appl. No. 17/797,661, 72 pages. [cited by applicant]
Boyd et al., “Convex Optimization”, Cambridge University Press, Cambridge, UK, ISBN: 978-0-521-83378-3, 730 pages (Mar. 2004). [cited by applicant]
“Multi-access Edge Computing (MEC); Radio Network Information API”, ETSI GS MEC 012 V2.1.1, 66 pages (Dec. 2019). [cited by applicant]
Ford et al., “TCP Extensions for Multipath Operation with Multiple Addresses”, Internet Engineering Task Force (IETF), Internet Draft, draft-ietf-mptcp-multiaddressed-09, 62 pages (Jun. 6, 2012), https://datatracker.iet… [cited by applicant]
“Intel® Network Edge Virtualization (NEV) Software Development Kit”, Intel Corp., Intel® Network Edge Virtualization Product Brief, 3 pages (Aug. 16, 2015), https://networkbuilders.intel.com/docs/Intel_Wireless_Product_… [cited by applicant]
“Simplify Application Development for the Network Edge”, Intel Corp., Service Provider NFV, White Paper, 5 pages (Sep. 26, 2018), https://www.intel.com/content/dam/www/public/us/en/documents/white-papers/nev-sdk-white-p… [cited by applicant]
“O-RAN Architecture Description”, O-RAN Alliance, O-RAN-WG1-O-RAN Architecture Description, v01.00.00, 24 pages (Feb. 2020). [cited by applicant]
“O-RAN Working Group 2, AI/ML workflow description and requirements”, O-RAN Alliance, ORAN-WG2.AIML, v01.00, 34 pages (Dec. 2019). [cited by applicant]
Singh et al., “Optimal Traffic Aggregation in Multi-RAT Heterogeneous Wireless Networks”, IEEE ICC2016—Workshops: W09-Workshop on 5G RAN Design, 6 pages (Mar. 7, 2016). [cited by applicant]
Zhu et al., “Generic Multi-Access (GMA) Convergence Encapsulation Protocols”, Intarea/Network Working Group, Internet Draft, draft-zhu-intarea-gma-04, 10 pages (Sep. 30, 2019), https://datatracker.ietf.org/doc/pdf/draft… [cited by applicant]
Zhu et al., “Generic Multi-Access (GMA) Convergence Encapsulation Protocols”, Intarea/Network Working Group, Internet Draft, draft-zhu-intarea-gma-05, 12 pages (Dec. 16, 2019), https://datatracker.ietf.org/doc/pdf/draft… [cited by applicant]
Extended European Search Report mailed May 10, 2023 for European Patent Application No. 20806061.6, 11 pages. [cited by applicant]
S. Kanugovi Nokia et al., “Multiple Access Management Services; Draft-Kanugovi-intarea-mams-fraaework-03”, (Feb. 28, 2019), 141 pages. [cited by applicant]
3GPP, “3rd Generation Partnership Project; Technical Specification Group Services and System Aspects; Study on access traffic steering, switch and splitting support in the 5G system architecture (Release 16)”, 3GPP TR 2… [cited by applicant]
G. Dommety, “Key and Sequence Number Extensions to GRE”, Internet Engineering Task Force (IETF) RFC 2890, 7 pages (Sep. 2000). [cited by applicant]
A. Huttunen et al., “UDP Encapsulation of IPsec ESP Packets”, Internet Engineering Task Force (IETF) RFC 3984, 15 pages (Jan. 2005). [cited by applicant]
A. Ford et al., “TCP Extensions for Multipath Operation with Multiple Addresses”, Internet Engineering Task Force (IETF) RFC 6824, 64 pages (Jan. 2013). [cited by applicant]
N. Leymann et al., “Huawei's GRE Tunnel Bonding Protocol”, Internet Engineering Task Force (IETF) RFC 81557, 44 pages (May 2017). [cited by applicant]
S. Kanugovi et al., “Multi-Access Management Services (MAMS)”, Internet Engineering Task Force (IETF) RFC 8743, 143 pages (Mar. 2020). [cited by applicant]
J. Zhu et al., “Generic Multi-Access (GMA) Encapsulation Protocol”, Internet Engineering Task Force (IETF) RFC 9188, 15 pages (Feb. 2022). [cited by applicant]
Extended European Search Report mailed Apr. 14, 2023 for European Patent Application No. 22203400.1, 13 pages. [cited by applicant]
Sangeetha Bangolae et al., “Performance Study of Fast BSS Transition using IEEE 802.11r”, Proceedings of the 2006 Int'l Conference on Wireless Comm. and Mobile Computing (IWCMC '06), pp. 737-742 (Jul. 3, 2006), https://… [cited by applicant]
“Wi-Fi Roaming Aggressiveness Setting”, Intel Corporation, Article ID 000005546, 2 pages (Oct. 28, 2021). [cited by applicant]
Yordan, “Oppo and vivo announce Dual Wi-Fi for their flagships”, GSMArena.com, 3 pages (Jul. 18, 2019), https://www.gsmarena.com/oppo_vivo_dual_wifi-news-38203.php. [cited by applicant]
Q. De Coninck et al., “Multipath Extensions for QUIC (MP-QUIC)”, IETF, draft-deconinck-quic-multipath-07, 36 pages (May 3, 2021), https://datatracker.ietf.org/doc/html/draft-deconinck-quic-multipath-07. [cited by applicant]
J. Zhu et al., “Generic Multi-Access (GMA) Encapsulation Protocol”, IETF, draft-zhu-intarea-gma-14, 17 pages (Nov. 24, 2021), https://datatracker.ietf.org/doc/html/draft-zhu-intarea-gma-14. [cited by applicant]
J. Zhu et al., “User-Plane Protocols for Multiple Access Management Service”, IETF, draft-zhu-intarea-mams-user-protocol-09, 8 pages (Mar. 4, 2020). [cited by applicant]
“3rd Generation Partnership Project; Technical Specification Group Core Network and Terminals; 5G System; Access Traffic Steering, Switching and Splitting (ATSSS); Stage 3 (Release 17)”, 3GPP TS 24.193 v17.2.0 (Sep. 24,… [cited by applicant]
“3rd Generation Partnership Project; Technical Specification Group Core Network and Terminals; Access Network Discovery and Selection Function (ANDSF) Management Object (MO) (Release 16)”, 3GPP TS 24.312 v16.0.0 (Jul. 9… [cited by applicant]
“3rd Generation Partnership Project; Technical Specification Group Radio Access Network; Evolved Universal Terrestrial Radio Access (E-UTRA); LTE/WLAN Radio Level Integration Using IPsec Tunnel (LWIP) encapsulation; Pro… [cited by applicant]
Office Action mailed Mar. 6, 2024 for U.S. Appl. No. 17/469,331, 96 pages. [cited by applicant]