IP Library › Granted Patent US 12,706,961
Granted Patent B2
US 12,706,961 · App. 18/393,214 · Granted Aug 11, 2026

System and method for sharing a sip communication service identifier

Inventors: Jan Hendrik Lucas Bakker (Fort Worth, TX); Andrew Michael Allen (Hallandale Beach, FL); Adrian Buckley (Tracy, CA)
Assignee: Malikie Innovations Limited
H04L65/1063H04L65/1016H04L65/1104
View Patent ↗
Loading inventors, assignments & file history…
Monitor This Case
Get email alerts when status or documents change.
Order Certified Copies
Most orders are placed with the USPTO same day — all within 24 business hours.
Order via The Patent Place →
Pre-filled with this patent's details
Quick Facts
Patent No.
US 12,706,961
App. No.
18/393,214
Filed
Dec 21, 2023
Granted
Aug 11, 2026
Kind
B2
Art Unit
2645
USPC
709/217
Abstract

A method for providing a user agent (UA) with service identification data. The method includes an application server (AS) transmitting Session Initiation Protocol (SIP) data. The SIP data comprises an identifier of the AS and a service identifier for at least one service supported by the AS. The method further includes the UA receiving the SIP data.

Claims (30)

1 . A method for indicating an application server (AS) capability, the method comprising:

generating, at the AS, a Session Initiation Protocol (SIP) request including a SIP header comprising a token that identifies at least one service supported by the AS and the SIP request further including an address of the AS, wherein the address is a uniform resource identifier (URI) that is included in a Record-Route header, wherein the AS is included in a signaling route;

transmitting, by the AS, the SIP request; and

transmitting, by the AS, a SIP response including the token.

2 . The method of claim 1 wherein the URI is a Globally Routable UA URI (GRUU).

3 . The method of claim 1 wherein the token indicates whether the at least one service is provided by the AS as an originating AS or a terminating AS.

4 . The method of claim 1 wherein the token is an IP (Internet Protocol) Multimedia Subsystem (IMS) Communication Service Identifier (ICSI).

5 . The method of claim 4 wherein the URI includes a URI parameter set equal to an ICSI value for a particular service provided by the AS.

6 . The method of claim 5 wherein the URI parameter is a g.3gpp.app_ref tag.

7 . The method of claim 1 wherein a SIP request that the AS receives from a first UA is a SIP INVITE message.

8 . The method of claim 1 wherein the token is associated with the at least one service by one of:

a hard coding of the association; and

execution of an algorithm that performs the association.

9 . A network component comprising a processor configured to:

generate, at the network component, a Session Initiation Protocol (SIP) request including a SIP header comprising a token that identifies at least one service supported by the network component, the SIP request further including an address of the network component, wherein the address is a uniform resource identifier (URI) that is included in a Record-Route header;

transmit by the network component, the SIP request; and

transmit, by the network component, a SIP response including the token.

10 . The network component of claim 9 wherein the URI is a Globally Routable UA URI (GRUU).

11 . The network component of claim 10 wherein the URI contains a ‘gr’ parameter.

12 . The network component of claim 9 wherein the token is an IP (Internet Protocol) Multimedia Subsystem (IMS) Communication Service Identifier (ICSI).

13 . The network component of claim 12 wherein the URI includes a URI parameter that is set equal to the ICSI.

14 . The network component of claim 13 wherein the URI parameter is a g.3gpp.app_ref tag.

15 . The network component of claim 9 , further comprising; receiving, by the network component, a SIP invite from a user agent before generating the SIP request.

16 . The network component of claim 15 wherein a user portion of the URI identifies at least one of:

a user agent that originated the SIP INVITE message; and

a user agent that terminates the SIP INVITE message.

17 . The network component of claim 15 wherein the network component is a telephony application server.

18 . The network component of claim 9 wherein the token is associated with the at least one service by one of:

a hard coding of the association; and

execution of an algorithm that performs the association.

Continuity (6)
Continuation 17896833 · Aug 26, 2022
Continuation 17112636 · Dec 4, 2020
Continuation 13529088 · Jun 21, 2012
Continuation 12209032 · Sep 11, 2008
Provisional Application 60971495 · Sep 11, 2007
Related Publication 20240129344A1 · Apr 18, 2024
References Cited (54)
US 6807173B1 · Lee et al. · 2004 [cited by applicant]
US 6888828B1 · Partanen · 2005 [cited by examiner]
US 8249561B2 · Bakker et al. · 2012 [cited by applicant]
US 10887352B2 · Bakker et al. · 2021 [cited by applicant]
US 11463487B2 · Bakker et al. · 2022 [cited by applicant]
US 20020172338A1 · Lee et al. · 2002 [cited by applicant]
US 20050058125A1 · Mutikainen et al. · 2005 [cited by applicant]
US 20050220095A1 · Narayanan · 2005 [cited by examiner]
US 20060031536A1 · Eydelman et al. · 2006 [cited by applicant]
US 20060047840A1 · Postmus · 2006 [cited by examiner]
US 20060212511A1 · Garcia-Martin · 2006 [cited by applicant]
US 20070002779A1 · Lee et al. · 2007 [cited by applicant]
US 20070260739A1 · Buckley et al. · 2007 [cited by applicant]
US 20080132161A1 · Chen et al. · 2008 [cited by applicant]
US 20080159262A1 · Crable et al. · 2008 [cited by applicant]
US 20080170563A1 · Zhu et al. · 2008 [cited by applicant]
US 20080189414A1 · Astrom · 2008 [cited by examiner]
US 20080244709A1 · George · 2008 [cited by examiner]
US 20090067411A1 · Heidermark et al. · 2009 [cited by applicant]
US 20220417292A1 · Bakker et al. · 2022 [cited by applicant]
Johnston, A., et al., “Session Initiation Protocol Service Examples”, Jul. 16, 2007—pp. 1-163, (Year: 2007). [cited by examiner]
3GGP TS 24.173 V7.1.0; 3rd Generation Partnership Project; Technical Specification Group Core Network and Terminals; IMS Multimedia Telephony Communication Service and Supplementary Services; Stage 3; Release 7; Jun. 20… [cited by applicant]
3GGP TS 24.229 V6.15.0; 3rd Generation Partnership Project; Technical Specification Group Core Network and Terminals; IP Multimedia Call Control Protocol based on Session Initiation Protocol (SIP) and Session Descriptio… [cited by applicant]
Johnston, A., et al.; “Session Initiation Protocol Service Examples”; draft-ietf-sipping-service-examples-13; Jul. 16, 2007; 163 pages. [cited by applicant]
ETSI TS 123 228 v7.8.0; Digital Cellular Telecommunications System (Phase 2+); Universal Mobile Telecommunications System (UMTS); IP Multimedia Subsystem (IMS); Stage 2; (3GPP TS 23.228 version 7.8.0 Release 7); Jun. 20… [cited by applicant]
Rosenberg, J.; “Obtaining and Using Globally Routable User Agent (UA) URIs (GRUU) in the Session Initiation Protocol (SIP)”; draft-ietf-sip-gruu-11; Oct. 23, 2006; 33 pages. [cited by applicant]
Handley, M., et al.; “SDP: Session Description Protocol”; RFC 4566; Jul. 2006; 46 pages. [cited by applicant]
3GPP TSG CT1 Meeting #48; “Definition of Feature Tag for IARI/ICSI”; C1-071832; Vienna, Austria; Aug. 20-24, 2007; 19 pages. [cited by applicant]
Drage, K.; “A Session Initiation Protocol (SIP) Extension for the Identification of Services”; draft-drage-sipping-service-identification-01; Jul. 9, 2007; 22 pages. [cited by applicant]
Handley, M., et al.; “SIP: Session Initiation Protocol”; RFC 2543 Mar. 1999; 143 pages. [cited by applicant]
Rosenberg, J., et al.; “Session Initiation Protocol (SIP): Locating SIP Servers”; RFC 3263; Jun. 2002; 8 pages. [cited by applicant]
Schulzrinne, Henning, et al.; “Application-Layer Mobility Using SIP”; IEEE; 2000; 8 pages. [cited by applicant]
Rosenberg, J., et al.; “SIP: Session Initiation Procol”; RFC 3261; Jun. 2002; 252 pages. [cited by applicant]
Office Action dated Jul. 22, 2011; U.S. Appl. No. 12/209,032, filed Sep. 11, 2008; 21 pages. [cited by applicant]
Final Office Action dated Nov. 4, 2011; U.S. Appl. No. 12/209,032, filed Sep. 11, 2008; 16 pages. [cited by applicant]
Advisory Action dated Jan. 12, 2012; U.S. Appl. No. 12/209,032, filed Sep. 11, 2008; 3 pages. [cited by applicant]
Notice of Allowance dated May 25, 2012; U.S. Appl. No. 12/209,032, filed Sep. 11, 2008; 14 pages. [cited by applicant]
Office Action dated Jul. 20, 2012; U.S. Appl. No. 13/529,088, filed Jun. 21, 2012; 28 pages. [cited by applicant]
Final Office Action dated Jan. 23, 2013; U.S. Appl. No. 13/529,088, filed Jun. 21, 2012; 26 pages. [cited by applicant]
Advisory Action dated Apr. 4, 2013; U.S. Appl. No. 13/529,088, filed Jun. 21, 2012; 3 pages. [cited by applicant]
Office Action dated Dec. 13, 2016; U.S. Appl. No. 13/529,088, filed Jun. 21, 2012; 21 pages. [cited by applicant]
Final Office Action dated Apr. 28, 2017; U.S. Appl. No. 13/529,088, filed Jun. 21, 2012; 23 pages. [cited by applicant]
Office Action dated Dec. 22, 2017; U.S. Appl. No. 13/529,088, filed Jun. 21, 2012; 23 pages. [cited by applicant]
Final Office Action dated Jun. 14, 2018; U.S. Appl. No. 13/529,088, filed Jun. 21, 2012; 23 pages. [cited by applicant]
Advisory Action dated Sep. 17, 2018; U.S. Appl. No. 13/529,088, filed Jun. 21, 2012; 5 pages. [cited by applicant]
Notice of Allowance dated Sep. 17, 2020; U.S. Appl. No. 13/529,088, filed Jun. 21, 2012; 9 pages. [cited by applicant]
Office Action dated Mar. 25, 2022; U.S. Appl. No. 17/112,636, filed Dec. 4, 2020; 28 pages. [cited by applicant]
Notice of Allowance dated Jun. 23, 2022; U.S. Appl. No. 17/112,636, filed Dec. 4, 2020; 9 pages. [cited by applicant]
Office Action dated Mar. 22, 2023; U.S. Appl. No. 17/896,833, filed Aug. 26, 2022; 22 pages. [cited by applicant]
Notice of Allowance dated Aug. 9, 2023; U.S. Appl. No. 17/896,833, filed Aug. 26, 2022; 9 pages. [cited by applicant]
PCT Invitation to Pay Additional Fees; PCT Application No. PCT/US2008/076035; Apr. 28, 2009; 5 pages. [cited by applicant]
PCT International Search Report; Application No. PCT/US2008/076035; Aug. 7, 2009; 6 pages. [cited by applicant]
PCT Written Opinion of the International Searching Authority; Application No. PCT/US2008/076035; Aug. 7, 2009; 9 pages. [cited by applicant]
PCT International Preliminary Report on Patentability; Application No. PCT/US2008/076035; Feb. 10, 2010; 15 pages. [cited by applicant]